diff options
author | chunrong guo <b40290@freescale.com> | 2013-03-21 03:49:13 +0000 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2013-03-27 14:07:04 +0800 |
commit | edce2242f5d4265ef7b2244b2f9e7cde57853732 (patch) | |
tree | a7301e769a23fd88cf8f359190eb53a36e56f879 /recipes-kernel/u-boot/u-boot_git.bb | |
parent | 82a7326851181713cbd6256dd832a6b35cc82f1d (diff) | |
download | meta-fsl-ppc-edce2242f5d4265ef7b2244b2f9e7cde57853732.tar.gz |
u-boot: update to the commit for sdk 1.3.2
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Diffstat (limited to 'recipes-kernel/u-boot/u-boot_git.bb')
-rw-r--r-- | recipes-kernel/u-boot/u-boot_git.bb | 29 |
1 files changed, 16 insertions, 13 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb index bc19bb4..e322ab7 100644 --- a/recipes-kernel/u-boot/u-boot_git.bb +++ b/recipes-kernel/u-boot/u-boot_git.bb | |||
@@ -5,16 +5,15 @@ PROVIDES = "virtual/bootloader" | |||
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" |
7 | 7 | ||
8 | PR = "r29" | 8 | PR = "r30" |
9 | INHIBIT_DEFAULT_DEPS = "1" | 9 | INHIBIT_DEFAULT_DEPS = "1" |
10 | DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc libgcc" | 10 | DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc libgcc" |
11 | 11 | ||
12 | inherit deploy | 12 | inherit deploy |
13 | 13 | ||
14 | SRCREV = "c6d9d502924ade8877f53eecdd5cf37e05d6d6b4" | 14 | SRCREV = "7bcd7f45c8974978f8eb73ae4d32e71cb6a49b77" |
15 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git" | 15 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git \ |
16 | SRCREV_e6500 = "9040d1ee41fc29fc7e9796bdfb59612f80bc1ee4" | 16 | " |
17 | SRCREV_e6500-64b = "9040d1ee41fc29fc7e9796bdfb59612f80bc1ee4" | ||
18 | python () { | 17 | python () { |
19 | ml = d.getVar("MULTILIB_VARIANTS", True) | 18 | ml = d.getVar("MULTILIB_VARIANTS", True) |
20 | arch = d.getVar("OVERRIDES", True) | 19 | arch = d.getVar("OVERRIDES", True) |
@@ -68,17 +67,21 @@ do_compile () { | |||
68 | if [ "${UBOOT_TARGET}" == "u-boot-sd" ]; then | 67 | if [ "${UBOOT_TARGET}" == "u-boot-sd" ]; then |
69 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin | 68 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin |
70 | elif [ "${UBOOT_TARGET}" == "u-boot-nand" ];then | 69 | elif [ "${UBOOT_TARGET}" == "u-boot-nand" ];then |
71 | if [ "${DEFAULTTUNE}" != "ppce500v2" ];then | 70 | if [ "${DEFAULTTUNE}" = "ppce500v2" ];then |
71 | if echo $board |egrep "(P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB)" 2>&1 >/dev/null;then | ||
72 | cp ${S}/${board}/u-boot-with-spl.bin ${S}/${board}/${UBOOT_TARGET}.bin | ||
73 | fi | ||
74 | else | ||
72 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin | 75 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin |
73 | fi | 76 | fi |
74 | else | 77 | else |
75 | if [ -n "${BOOTFORMAT_CONFIG}" ];then | 78 | if [ -n "${BOOTFORMAT_CONFIG}" ];then |
76 | ${STAGING_BINDIR_NATIVE}/boot_format \ | 79 | ${STAGING_BINDIR_NATIVE}/boot_format \ |
77 | ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \ | 80 | ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \ |
78 | ${S}/${board}/u-boot.bin -spi ${S}/${board}/${UBOOT_TARGET}.bin | 81 | ${S}/${board}/u-boot.bin -spi ${S}/${board}/${UBOOT_TARGET}.bin |
79 | else | 82 | else |
80 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin | 83 | cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin |
81 | fi | 84 | fi |
82 | fi | 85 | fi |
83 | fi | 86 | fi |
84 | done | 87 | done |
@@ -133,4 +136,4 @@ addtask deploy after do_install | |||
133 | PACKAGES += "${PN}-images" | 136 | PACKAGES += "${PN}-images" |
134 | FILES_${PN}-images += "/boot" | 137 | FILES_${PN}-images += "/boot" |
135 | 138 | ||
136 | ALLOW_EMPTY = "1" | 139 | ALLOW_EMPTY_${PN} = "1" |