summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-09-24 21:08:35 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-09-24 21:08:35 +0800
commit28b7ac5a37a9705d090d7303a024d84efef61b89 (patch)
treeb316ee5921137ec0a1afeca5bb6223c1d944f235 /recipes-kernel/linux
parent9bc331b70449886bb24517529923d6305dbe1233 (diff)
downloadmeta-fsl-ppc-28b7ac5a37a9705d090d7303a024d84efef61b89.tar.gz
Remove overriding linux-libc-headers
Layers should never need to be overriding linux-libc-headers. Refer to http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=babbf7a46acaefd9b36031483cafce053f607e66 for the reason. Fixed [Bug 5249]. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/files/scripts-Makefile.headersinst-install-headers-from-sc.patch46
-rw-r--r--recipes-kernel/linux/linux-qoriq-sdk-headers.bb34
2 files changed, 0 insertions, 80 deletions
diff --git a/recipes-kernel/linux/files/scripts-Makefile.headersinst-install-headers-from-sc.patch b/recipes-kernel/linux/files/scripts-Makefile.headersinst-install-headers-from-sc.patch
deleted file mode 100644
index 0f28d3d..0000000
--- a/recipes-kernel/linux/files/scripts-Makefile.headersinst-install-headers-from-sc.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From e60cc1b011bf0f1acdb7e5168b7bed4ebb78c91f Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 9 Jan 2013 16:24:39 -0500
4Subject: [PATCH] scripts/Makefile.headersinst: install headers from scratch file
5
6If headers_install is executed from a deep/long directory structure, the
7shell's maximum argument length can be execeeded, which breaks the operation
8with:
9
10| make[2]: execvp: /bin/sh: Argument list too long
11| make[2]: ***
12
13By dumping the input files to a scratch file and using xargs to read the
14input list from the scratch file, we can avoid blowing out the maximum
15argument size and install headers in a long path name environment.
16
17Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
18---
19 scripts/Makefile.headersinst | 4 +++-
20 1 files changed, 3 insertions(+), 1 deletions(-)
21
22diff --git a/scripts/Makefile.headersinst b/scripts/Makefile.headersinst
23index 06ba4a7..536d722 100644
24--- a/scripts/Makefile.headersinst
25+++ b/scripts/Makefile.headersinst
26@@ -71,7 +71,7 @@ printdir = $(patsubst $(INSTALL_HDR_PATH)/%/,%,$(dir $@))
27 quiet_cmd_install = INSTALL $(printdir) ($(words $(all-files))\
28 file$(if $(word 2, $(all-files)),s))
29 cmd_install = \
30- $(PERL) $< $(installdir) $(SRCARCH) $(input-files); \
31+ xargs $(PERL) $< $(installdir) $(SRCARCH) < $(INSTALL_HDR_PATH)/.input-files; \
32 for F in $(wrapper-files); do \
33 echo "\#include <asm-generic/$$F>" > $(installdir)/$$F; \
34 done; \
35@@ -100,7 +100,9 @@ targets += $(install-file)
36 $(install-file): scripts/headers_install.pl $(input-files) FORCE
37 $(if $(unwanted),$(call cmd,remove),)
38 $(if $(wildcard $(dir $@)),,$(shell mkdir -p $(dir $@)))
39+ @echo $(input-files) > $(INSTALL_HDR_PATH)/.input-files
40 $(call if_changed,install)
41+ @rm $(INSTALL_HDR_PATH)/.input-files
42
43 else
44 __headerscheck: $(subdirs) $(check-file)
45--
461.7.0.4
diff --git a/recipes-kernel/linux/linux-qoriq-sdk-headers.bb b/recipes-kernel/linux/linux-qoriq-sdk-headers.bb
deleted file mode 100644
index 0ee4fc1..0000000
--- a/recipes-kernel/linux/linux-qoriq-sdk-headers.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1DESCRIPTION = "Linux kernel headers for Freescale platforms"
2SECTION = "devel"
3LICENSE = "GPLv2"
4
5PR = "${INC_PR}.1"
6
7INHIBIT_DEFAULT_DEPS = "1"
8PROVIDES = "linux-libc-headers ${PN}"
9RPROVIDES_${PN}-dev += "linux-libc-headers-dev"
10RPROVIDES_${PN}-dbg += "linux-libc-headers-dbg"
11RDEPENDS_${PN}-dev = ""
12RRECOMMENDS_${PN}-dbg = "linux-libc-headers-dev (= ${EXTENDPKGV})"
13
14require recipes-kernel/linux/linux-qoriq-sdk.inc
15
16SRC_URI_append += " file://scripts-Makefile.headersinst-install-headers-from-sc.patch"
17
18inherit kernel-arch
19
20do_configure() {
21 oe_runmake allnoconfig
22}
23
24do_compile () {
25}
26
27do_install() {
28 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}
29 # Kernel should not be exporting this header
30 rm -f ${D}${exec_prefix}/include/scsi/scsi.h
31
32 # The ..install.cmd conflicts between various configure runs
33 find ${D}${includedir} -name ..install.cmd | xargs rm -f
34}