summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.1.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-16 17:07:46 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:41:54 +0800
commitb1fcfb28a4d1b7ddf9b393b697d76256cc52f760 (patch)
tree63a39e93a66fe2521549378e6c0568b08cbc99c2 /recipes-kernel/linux/linux-qoriq_4.1.bb
parentad53934bfb7602362eff7fc27878ca0e6b42882a (diff)
downloadmeta-fsl-ppc-b1fcfb28a4d1b7ddf9b393b697d76256cc52f760.tar.gz
linux-qoriq: upgrade to 4.1
The main features are: * Linux kernel 4.1.8 * ARM A7 (AARCH32), A53 and A57 (AARCH64), Little Endian (default) * Power Architecture e500mc, e5500, e6500 * Multicore SMP support and multithread (e6500) * 32-bit effective kernel addressing [e500mc, e5500, A57] * 64-bit effective addressing [e6500, A53, A57] * Huge Pages (hugetlbfs) * Linux Real-Time (RT) [P4080, B4860, LS1021A] * Kernel-based Virtual Machine (KVM) * Libvirt 1.2.19 * Linux Containers (LXC) 1.1.4 function support Detailed commit log can be found at: http://git.freescale.com/git/cgit.cgi/ppc/sdk/linux.git/log/?h=sdk-v2.0.x Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.1.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb
new file mode 100644
index 0000000..87eebbc
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bb
@@ -0,0 +1,56 @@
1inherit kernel kernel-arch qoriq_build_64bit_kernel
2require recipes-kernel/linux/linux-dtb.inc
3
4DESCRIPTION = "Linux kernel for Freescale platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v2.0.x \
10 file://modify-defconfig-t1040-nr-cpus.patch \
11 file://fix-the-compile-issue-under-gcc6.patch \
12"
13SRCREV = "bd51baffc04ecc73f933aee1c3a37c8b44b889a7"
14
15KSRC ?= ""
16S = '${@base_conditional("KSRC", "", "${WORKDIR}/git", "${KSRC}", d)}'
17
18DEPENDS_append = " libgcc"
19# not put Images into /boot of rootfs, install kernel-image if needed
20RDEPENDS_kernel-base = ""
21
22KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
23KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
24
25SCMVERSION ?= "y"
26DELTA_KERNEL_DEFCONFIG ?= ""
27do_configure_prepend() {
28 # copy desired defconfig so we pick it up for the real kernel_do_configure
29 cp ${KERNEL_DEFCONFIG} ${B}/.config
30
31 # add config fragments
32 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
33 if [ -f "${deltacfg}" ]; then
34 ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg}
35 elif [ -f "${WORKDIR}/${deltacfg}" ]; then
36 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
37 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then
38 ${S}/scripts/kconfig/merge_config.sh -m .config \
39 ${S}/arch/${ARCH}/configs/${deltacfg}
40 fi
41 done
42
43 #add git revision to the local version
44 if [ "${SCMVERSION}" = "y" ]; then
45 # append sdk version if SDK_VERSION is defined
46 sdkversion=''
47 if [ -n "${SDK_VERSION}" ]; then
48 sdkversion="-${SDK_VERSION}"
49 fi
50 head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
51 printf "%s%s%s" $sdkversion +g $head > ${B}/.scmversion
52 fi
53}
54
55# make everything compatible for the time being
56COMPATIBLE_MACHINE_$MACHINE = "$MACHINE"