summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-07-17 05:51:13 -0500
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-17 19:04:14 +0800
commitbbedd22907e1c5f45b07179e22b567bceb3596d5 (patch)
treefb9e2ba5e871c8ef8866963071ad093435fb0af9 /recipes-kernel/linux/files
parentd8f99ceb11128bfc982d623a38777bcbb80cfa8a (diff)
downloadmeta-fsl-ppc-bbedd22907e1c5f45b07179e22b567bceb3596d5.tar.gz
perf: Remove hard coded include to /usr/local/include in Makefile
Having /usr/local/include hardcoded into the makefile is not necessary as this is automatically included by GCC. It also infects cross-compile builds with the host systems includes. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-kernel/linux/files')
-rw-r--r--recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch b/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch
new file mode 100644
index 0000000..15c397d
--- /dev/null
+++ b/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch
@@ -0,0 +1,36 @@
1Upstream-Status: Backport
2
3From b9e8c37220c80e78289a1e87b50c09418eb59a7e Mon Sep 17 00:00:00 2001
4From: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
5Date: Fri, 08 Mar 2013 11:21:52 +0000
6Subject: libtraceevent: Remove hard coded include to /usr/local/include in Makefile
7
8having /usr/local/include hardcoded into the makefile is not necessary
9as this is automatically included by GCC. It also infects cross-compile
10builds with the host systems includes.
11
12Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
13Acked-by: Namhyung Kim <namhyung@kernel.org>
14Cc: Ingo Molnar <mingo@redhat.com>
15Cc: Paul Mackerras <paulus@samba.org>
16Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
17Link: http://lkml.kernel.org/r/1362741712-21308-1-git-send-email-ml@communistcode.co.uk
18Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
19---
20(limited to 'tools/lib/traceevent/Makefile')
21
22diff --git a/tools/lib/traceevent/Makefile b/tools/lib/traceevent/Makefile
23index a20e320..0b0a907 100644
24--- a/tools/lib/traceevent/Makefile
25+++ b/tools/lib/traceevent/Makefile
26@@ -122,7 +122,7 @@ export Q VERBOSE
27
28 EVENT_PARSE_VERSION = $(EP_VERSION).$(EP_PATCHLEVEL).$(EP_EXTRAVERSION)
29
30-INCLUDES = -I. -I/usr/local/include $(CONFIG_INCLUDES)
31+INCLUDES = -I. $(CONFIG_INCLUDES)
32
33 # Set compile option CFLAGS if not set elsewhere
34 CFLAGS ?= -g -Wall
35--
36cgit v0.9.2