summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-13 18:27:38 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-14 10:44:56 +0800
commitc68e11b525b3e083c97872ec4c4f593b7a795c30 (patch)
tree19a3afcf797e3ac50353432ef5b5f6770d678bdc /recipes-extended
parentfe0429ee9f6f719e98c4c3aa5fe066c7ff802b3b (diff)
downloadmeta-fsl-ppc-c68e11b525b3e083c97872ec4c4f593b7a795c30.tar.gz
cst: upgrade revision to 2d35e98
This includes following fixes: 2d35e98 CST : Add P2041 support to cst. c8b29ef CST: initialize uninitialized variables 6d30fc3 Makefile: use CFLAGS environment variable 39a4b89 Makefile: add install rule 7e9d814 Makefile: check OPENSSL setting before use 4ce2fd1 Modify input files to add HASH_FILE and SIGN_FILE felds. 2934719 ls1: ie_key files modified 13cef32 ls1: Remove extra keys from input file in ls1 14660b8 Modify input files to make consisitency with images. 6dbd697 Modify signature offset. b6d3fe6 input_files/uni_sign: Updated uboot binary name to u-boot.bin 2344105 IE Keys : Add input files 517b3d8 Fixed error handling for sign_embed tool. f711555 Modify ESBC header fields and use case for SRK and IE KEY. c9361dd sign_embed: it would embed signature over header passed. ec541fa gen_sign: it would calculate and generate signature over hash passed. 3b0a522 Modifications for changing argc to optind. 78cfdba Parsing of esbc flag is done prior of other fields. c0f49a8 Add feature of comparison of key pairs. c22c94f Add gen_drv tool. 7abb3e1 Modularise the key extraction from key file. 5ac9cd1 Add error handling for not supported values provided as input. 64eb9c4 Modify parsing of field values. c73ae3a Modify Makefile to discard compilation of uni_pbi tool. 8023fa1 Modify usage of gen_otpmk utility. 9065d2a Corrected the setting of FSL_UID and OEM_UID flag 7b688ed uni_pbi tool added 4ae8899 LS2 specific changes. 5e856de Add T2080 as target. 582fa00 Add input files for ie_key usage. f5ac295 Modify features enabled with different options. bcb3791 modify option available. 34c2290 Add key_ext option. 3abf8d3 Signature is moved to end. 7d58769 Add feature to accept externally generated signature. 43a917a Add export hash feature. d1877da Remove redundancy with keys usage. 9b049cb Add LS2 header support. 8b0044b Add IE key usage support for ESBC header. a684f4f support for ESBC header generation 63c901a Add ISBC Extension Key Feature. 746a9b9 Linked implementation for headers and tables 15ae37e Revert "LS1021: unisign fixed for group5" 54661bb Corrected LS1 input files. 5f58c80 Corrected dtb name in input file for LS1 dtb 8c0feeb LS1: Change the input file for NOR addresses Also sync with meta-fsl-arm.
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/cst/cst_git.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/recipes-extended/cst/cst_git.bb b/recipes-extended/cst/cst_git.bb
index 0ec883b..e9f1b6f 100644
--- a/recipes-extended/cst/cst_git.bb
+++ b/recipes-extended/cst/cst_git.bb
@@ -1,4 +1,4 @@
1DESCRIPTION = "CST Tool" 1SUMMARY = "utility for security boot"
2SECTION = "cst" 2SECTION = "cst"
3LICENSE = "BSD" 3LICENSE = "BSD"
4 4
@@ -7,23 +7,20 @@ LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5
7 7
8DEPENDS += "openssl" 8DEPENDS += "openssl"
9 9
10inherit kernel-arch
11
10SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1" 12SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1"
11SRCREV = "321b798b84cb5fe6564dfb233dea046e779d6f74" 13SRCREV = "2d35e98539c0daa2bc8049e3bd44994d3d93bbe7"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
15EXTRA_OEMAKE = 'OPENSSL_LIB_PATH=${STAGING_LIBDIR} OPENSSL_INC_PATH=${STAGING_INCDIR} CC="${CC}" LD="${CC}" LDFLAGS="${LDFLAGS}"' 17EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
18
19PARALLEL_MAKE = ""
16 20
17do_install () { 21do_install () {
18 install -d ${D}/${bindir}/cst 22 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
19 install -m 755 ${S}/gen_keys ${D}/${bindir}/cst/
20 install -m 755 ${S}/gen_otpmk ${D}/${bindir}/cst/
21 install -m 755 ${S}/uni_cfsign ${D}/${bindir}/cst/
22 install -m 755 ${S}/uni_sign ${D}/${bindir}/cst/
23 cp -rf ${S}/input_files ${D}/${bindir}/cst
24} 23}
25 24
26BBCLASSEXTEND = "native nativesdk"
27PARALLEL_MAKE = ""
28
29FILES_${PN}-dbg += "${bindir}/cst/.debug" 25FILES_${PN}-dbg += "${bindir}/cst/.debug"
26BBCLASSEXTEND = "native nativesdk"