summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-01-05 18:32:30 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-07 10:17:03 +0800
commita50750e38ca5872e0d8c04462af6cf522d7de43d (patch)
tree247b8126e82370571c9eb611aac97ed20da65471 /recipes-extended
parent3d15d71baadf1b5936cb704ff09eb645f0c72f99 (diff)
downloadmeta-fsl-ppc-a50750e38ca5872e0d8c04462af6cf522d7de43d.tar.gz
web-sysmon: update to revision 8d0c6ec
This includes following fixes: 8d0c6ec Using Makefile to install the package 7d7a893 Add PM demo scripts support 472c2b1 Add startup script for web-sysmon package ca33057 Add T4240QDS support 8508c8f Automatically scan hwmon system 522f8e2 Update the clean target of Makefile 24d3e4c Unify the template of temp/curr/in/power cgi script cd66d0f Update the clean target of Makefile c5dd6e8 Update description of sens_create_rrd Update recipe to match the code changes: 1. use 'oe_runmake install' 2. install web-sysmon.sh as init script Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/web-sysmon/web-sysmon_git.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/recipes-extended/web-sysmon/web-sysmon_git.bb b/recipes-extended/web-sysmon/web-sysmon_git.bb
index 506c0e1..84f60d5 100644
--- a/recipes-extended/web-sysmon/web-sysmon_git.bb
+++ b/recipes-extended/web-sysmon/web-sysmon_git.bb
@@ -4,18 +4,20 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 4LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
5 5
6SRC_URI = "git://git.freescale.com/ppc/sdk/web-sysmon-dev.git;nobranch=1" 6SRC_URI = "git://git.freescale.com/ppc/sdk/web-sysmon-dev.git;nobranch=1"
7SRCREV = "d8fafc6f223054a4129d5623e89d3dcf42ac8147" 7SRCREV = "8d0c6eca1113832fabe917fd0cb25abe2d4d7157"
8 8
9S = "${WORKDIR}/git" 9inherit update-rc.d
10 10
11FILES_${PN} += "/" 11S = "${WORKDIR}/git"
12 12
13RDEPENDS_${PN} = "lighttpd" 13RDEPENDS_${PN} = "lighttpd"
14 14
15do_install() { 15EXTRA_OEMAKE += "D=${D}"
16 install -d ${D}/etc 16do_install () {
17 install -m 644 ${S}/lighttpd.conf ${D}/etc 17 oe_runmake install
18 install -d ${D}/usr/local/bin
19 install -m 755 ${S}/rrd/sens_update_rrd ${D}/usr/local/bin
20 cp -r ${S}/rrd ${D}/usr
21} 18}
19
20FILES_${PN} += "/"
21
22INITSCRIPT_NAME = "web-sysmon.sh"
23INITSCRIPT_PARAMS = "defaults 99 20"