summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-12-14 11:12:13 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-01-12 18:06:01 +0800
commit822776251c9aad3c1875771d7b9272dcffd3fc52 (patch)
treef544d615407509fa1b8baf3df3bbc6725b7fa320 /recipes-extended
parent570a71b2adc61f3dff1a39f138dfb3dd5868bfe6 (diff)
downloadmeta-fsl-ppc-822776251c9aad3c1875771d7b9272dcffd3fc52.tar.gz
skmm-ep: add recipe
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
new file mode 100644
index 0000000..65659b9
--- /dev/null
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "SKMM application for PCIe endpoint"
2SECTION = "skmm-ep"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
5
6DEPENDS = "libedit openssl"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;nobranch=1"
9SRCREV = "448522aa1ba3f0c4a1481631dc1c3b168d410a61"
10
11COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"
12
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = 'MACHINE=${MACHINE}'
16
17export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
18export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
19
20do_compile () {
21 export ARCH=${TARGET_ARCH}
22 oe_runmake
23}
24
25do_install () {
26 oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D}
27}