summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-12-22 16:57:05 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-28 11:01:00 +0800
commit6f8a4a8a2da156ebea842cdf79e862c90c138ed5 (patch)
tree24345fd544cb64e82a9869906a631addab74c531 /recipes-extended
parent3e090b9330cf49246cd69f6161ee39e1c1e41ba3 (diff)
downloadmeta-fsl-ppc-6f8a4a8a2da156ebea842cdf79e862c90c138ed5.tar.gz
skmm-ep: add ARCH in EXTRA_OEMAKE
ARCH is needed for all tasks, for example, make clean Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
index 9446a74..24e64c8 100644
--- a/recipes-extended/skmm-ep/skmm-ep_git.bb
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -17,16 +17,15 @@ COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20EXTRA_OEMAKE = 'MACHINE=${MACHINE}' 20EXTRA_OEMAKE = 'ARCH=${TARGET_ARCH} MACHINE=${MACHINE}'
21 21
22export LIBEDIT_CFLAGS = "`pkg-config --cflags libedit`" 22export LIBEDIT_CFLAGS = "`pkg-config --cflags libedit`"
23export LIBEDIT_LDFLAGS = "`pkg-config --libs --static libedit`" 23export LIBEDIT_LDFLAGS = "`pkg-config --libs --static libedit`"
24 24
25do_compile () { 25do_compile () {
26 export ARCH=${TARGET_ARCH}
27 oe_runmake 26 oe_runmake
28} 27}
29 28
30do_install () { 29do_install () {
31 oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D} 30 oe_runmake install DESTDIR=${D}
32} 31}