summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-06-14 14:30:59 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:48 +0800
commit49736b0441df59d52006a6cdb533b3d0527571eb (patch)
treec6cbfd8c642b9aabcb711d303263f778d95ba4c7 /recipes-extended
parent85b40a1d06167b4f4f9949377c9f55c08584be64 (diff)
downloadmeta-fsl-ppc-49736b0441df59d52006a6cdb533b3d0527571eb.tar.gz
uspdcp: add recipe for sdk v1.6
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/uspdcp/uspdcp_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-extended/uspdcp/uspdcp_git.bb b/recipes-extended/uspdcp/uspdcp_git.bb
new file mode 100644
index 0000000..035aab5
--- /dev/null
+++ b/recipes-extended/uspdcp/uspdcp_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "SEC user space driver package"
2LICENSE = "BSD GPLv2"
3
4DEPENDS += "flib usdpaa"
5
6# no COPYING file in current git tree, need to be fixed
7LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=83b6209ab517640a7390536a08d33609"
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/uspdcp.git;nobranch=1"
10SRCREV = "30016cdf36553c14f7143ef005a4925edd901fb0"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE="ARCH=${TARGET_ARCH} EXTRA_DEFINE='USDPAA CONFIG_PHYS_64BIT' CROSS_COMPILE=${TARGET_PREFIX} SDK_DIR=${STAGING_DIR}/${MACHINE}"
15
16do_install(){
17 oe_runmake install DESTDIR=${D}
18}