summaryrefslogtreecommitdiffstats
path: root/recipes-extended/testfloat/testfloat_2a.bb
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-extended/testfloat/testfloat_2a.bb
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-extended/testfloat/testfloat_2a.bb')
-rw-r--r--recipes-extended/testfloat/testfloat_2a.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-extended/testfloat/testfloat_2a.bb b/recipes-extended/testfloat/testfloat_2a.bb
new file mode 100644
index 0000000..3fbb207
--- /dev/null
+++ b/recipes-extended/testfloat/testfloat_2a.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "A program for testing floating-point implementation"
2SECTION = "test"
3LICENSE = "Hauser TestFloat"
4
5LIC_FILES_CHKSUM = "file://testfloat/testfloat.txt;beginline=87;endline=95;md5=bdb2e8111838a48015c29bd97f5b6145"
6
7SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \
8 http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \
9 "
10SRC_URI_append_fslmachine = " file://SoftFloat-powerpc-1.patch \
11 file://TestFloat-powerpc-E500v2-SPE-1.patch \
12 file://Yocto-replace-COMPILE_PREFIX-gcc.patch \
13 "
14SRC_URI[TestFloat.md5sum] = "4dc889319ae1e0c5381ec511f784553a"
15SRC_URI[TestFloat.sha256sum] = "84d14aa42adefbda2ec9708b42946f7fa59f93689b042684bd027863481f8e4e"
16SRC_URI[SoftFloat.md5sum] = "b4a58b5c941f1a2317e4c2500086e3fa"
17SRC_URI[SoftFloat.sha256sum] = "89d14b55113a2ba8cbda7011443ba1d298d381c89d939515d56c5f18f2febf81"
18
19S = "${WORKDIR}/TestFloat-2a"
20
21do_unpack2(){
22 mv ${WORKDIR}/SoftFloat-2b ${S}/SoftFloat-2b
23 cd ${S}
24 if [ -n "$(which fromdos)" ];then
25 find -type f -exec fromdos {} \;
26 elif [ -n "$(which dos2unix)" ];then
27 find -type f -exec dos2unix {} \;
28 else
29 echo -e "\nERROR: command dos2unix or fromdos not found\n" && return 1
30 fi
31}
32addtask do_unpack2 after do_unpack before do_patch
33
34do_compile(){
35 oe_runmake -C testfloat/powerpc-linux-gcc/ CC="${CC}" EXTRA_CFLAGS="-DTEST_KERNEL_EMU"
36}
37
38do_install(){
39 install -d ${D}/${bindir}
40 install testfloat/powerpc-linux-gcc/testfloat ${D}/${bindir}
41 install testfloat/powerpc-linux-gcc/testsoftfloat ${D}/${bindir}
42}
43
44COMPATIBLE_HOST_e500v2 = ".*"
45COMPATIBLE_HOST ?= "(none)"
46