summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/usdpaa
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-dpaa/usdpaa
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa/usdpaa')
-rw-r--r--recipes-dpaa/usdpaa/usdpaa_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-dpaa/usdpaa/usdpaa_git.bb b/recipes-dpaa/usdpaa/usdpaa_git.bb
new file mode 100644
index 0000000..48e860f
--- /dev/null
+++ b/recipes-dpaa/usdpaa/usdpaa_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "User-Space Data-Path Acceleration Architecture drivers"
2LICENSE = "BSD & GPLv2"
3LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
4PR = "r4"
5
6inherit pkgconfig
7
8DEPENDS = "libxml2 libedit ncurses readline flib fmc"
9RDEPENDS_${PN} = "libgcc bash"
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git"
12SRCREV = "97fe45d9697ef339e10a1885539b23fa7fcb113e"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"'
17export ARCH="${TARGET_ARCH}"
18
19do_compile_prepend () {
20 case ${MACHINE} in
21 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) SOC=B4860;;
22 t4240qds|t4240qds-64b) SOC=T4240;;
23 p1023rdb) SOC=P1023;;
24 *) SOC=P4080;;
25 esac
26 export FMC_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmc"
27 export FMLIB_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmd \
28 -I ${STAGING_INCDIR}/fmd/Peripherals \
29 -I ${STAGING_INCDIR}/fmd/integrations \
30 -D $SOC"
31
32 export LIBXML2_CFLAGS="$(pkg-config --cflags libxml-2.0)"
33 export LIBXML2_LDFLAGS="$(pkg-config --libs --static libxml-2.0)"
34 export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
35 export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
36}
37
38do_install () {
39 oe_runmake install DESTDIR=${D}
40}
41
42PARALLEL_MAKE_pn-${PN} = ""
43FILES_${PN} += "/root/SOURCE_THIS /usr/etc/"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46
47COMPATIBLE_HOST_fslmachine = ".*"
48COMPATIBLE_HOST ?= "(none)"
49