summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fmlib
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-dpaa/fmlib
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa/fmlib')
-rw-r--r--recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch43
-rw-r--r--recipes-dpaa/fmlib/fmlib_git.bb43
2 files changed, 86 insertions, 0 deletions
diff --git a/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch b/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch
new file mode 100644
index 0000000..4894ce3
--- /dev/null
+++ b/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch
@@ -0,0 +1,43 @@
1From 67b539d256520f95f3c8101f4605ea6d496982df Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <b19537@freescale.com>
3Date: Thu, 18 Oct 2012 17:28:00 +0300
4Subject: [PATCH] fm-lib: make the library install path configurable
5
6currently library for both 32bit target and 64bit target
7is installed in /usr/lib folder, add a variable to make the
8install path configurable
9
10Signed-off-by: Zhenhua Luo <b19537@freescale.com>
11---
12 Makefile | 8 +++++---
13 1 file changed, 5 insertions(+), 3 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 06fe930..d59f44a 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -59,6 +59,8 @@ endif
20
21 INSTALL?=install
22
23+LIB_DEST_DIR?=$(PREFIX)/lib
24+
25 # Don't forget to increment .version before doing a new release!
26 FM_LIB_VERSION:=$(shell cat .version)
27
28@@ -118,9 +120,9 @@ archive: all .version
29
30 install-%: %.a
31 @(echo "Installing...")
32- @($(INSTALL) -d $(DESTDIR)$(PREFIX)/lib)
33- @($(INSTALL) $< $(DESTDIR)$(PREFIX)/lib)
34- @(ln -s $(DESTDIR)$(PREFIX)/lib/$< $(DESTDIR)$(PREFIX)/lib/libfm.a)
35+ @($(INSTALL) -d $(DESTDIR)$(LIB_DEST_DIR))
36+ @($(INSTALL) $< $(DESTDIR)$(LIB_DEST_DIR))
37+ @(ln -s $(DESTDIR)$(LIB_DEST_DIR)/$< $(DESTDIR)$(LIB_DEST_DIR)/libfm.a)
38 @(cp -r -p ./include $(DESTDIR)$(PREFIX))
39 @($(INSTALL) -d $(DESTDIR)$(PREFIX)/share/doc/fm-lib-$(FM_LIB_VERSION))
40 @($(INSTALL) $(FM_LIB_DOCFILES) $(DESTDIR)$(PREFIX)/share/doc/fm-lib-$(FM_LIB_VERSION))
41--
421.7.9.5
43
diff --git a/recipes-dpaa/fmlib/fmlib_git.bb b/recipes-dpaa/fmlib/fmlib_git.bb
new file mode 100644
index 0000000..7a7b8f2
--- /dev/null
+++ b/recipes-dpaa/fmlib/fmlib_git.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Frame Manager User Space Library"
2SECTION = "fman"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3f16fa8e677e45af3127c5c4bafc3c00"
5
6PR = "r1"
7
8DEPENDS = "linux-libc-headers"
9DEPENDS_virtclass-native = ""
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git"
12SRCREV = "7d843485bdac963d98f81773c0f3cb15936e09da"
13
14S = "${WORKDIR}/git"
15
16TARGET_ARCH_FMLIB = "${DEFAULTTUNE}"
17TARGET_ARCH_FMLIB_e5500 = "ppc32e5500"
18TARGET_ARCH_FMLIB_e6500 = "ppc32e6500"
19COMPATIBLE_HOST_fslmachine = ".*"
20COMPATIBLE_HOST ?= "(none)"
21
22EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \
23 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_EXECPREFIXDIR}"
24
25do_compile () {
26 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a
27}
28
29do_compile_virtclass-native () {
30}
31
32do_install () {
33 oe_runmake install-libfm-${TARGET_ARCH_FMLIB}
34}
35
36do_install_virtclass-native () {
37 install -d ${D}/${includedir}
38 cp -rf ${S}/include/* ${D}/${includedir}
39}
40
41ALLOW_EMPTY_${PN} = "1"
42
43BBCLASSEXTEND = "native"