summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fmc
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-dpaa/fmc
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa/fmc')
-rw-r--r--recipes-dpaa/fmc/fmc_git.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-dpaa/fmc/fmc_git.bb b/recipes-dpaa/fmc/fmc_git.bb
new file mode 100644
index 0000000..20f93f6
--- /dev/null
+++ b/recipes-dpaa/fmc/fmc_git.bb
@@ -0,0 +1,53 @@
1DESCRIPTION = "Frame Manager Configuration tool"
2SECTION = "fmc"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a504ab5a8ff235e67c7301214749346c"
5
6PR = "r2"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git"
9SRCREV = "f2e1a831a96f1d04d3d5a5970d2e54c38098cf39"
10
11DEPENDS = "libxml2 fmlib tclap"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
18 FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
19 TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
20EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
21 FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
22 TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
23
24PARALLEL_MAKE = ""
25
26do_compile () {
27 if [ "b4860qds" = "${MACHINE}" ] || [ "b4420qds" = "${MACHINE}" ];then
28 EXTRA_OEMAKE_PLATFORM="b4860qds"
29 elif [ "t4240qds" = "${MACHINE}" ] || [ "t4160qds" = "${MACHINE}" ];then
30 EXTRA_OEMAKE_PLATFORM="t4240qds"
31 elif [ "p1023rds" = "${MACHINE}" ];then
32 EXTRA_OEMAKE_PLATFORM="p1023rds"
33 else
34 EXTRA_OEMAKE_PLATFORM=""
35 fi
36 oe_runmake MACHINE=${EXTRA_OEMAKE_PLATFORM} -C source
37}
38
39do_install () {
40 install -d ${D}/${bindir}
41 install -m 755 ${S}/source/fmc ${D}/${bindir}/fmc
42
43 install -d ${D}/etc/fmc/config
44 install -m 644 ${S}/etc/fmc/config/hxs_pdl_v3.xml ${D}/etc/fmc/config
45
46 install -d ${D}/${includedir}/fmc
47 install ${S}/source/fmc.h ${D}/${includedir}/fmc
48
49 install -d ${D}/${libdir}
50 install ${S}/source/libfmc.a ${D}/${libdir}
51}
52
53BBCLASSEXTEND = "native"