summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-03-20 17:06:57 -0500
committerMatthew McClintock <msm@freescale.com>2012-03-20 18:49:28 -0500
commitdd42796ad1cf8cb23b004556cee5dea4821d0d5f (patch)
tree2490a18daec0a910baaaca2cb31878faf1163d02 /recipes-devtools
parentfd124c27c453d1b1545bbb1c09155ffe7365416f (diff)
downloadmeta-fsl-ppc-dd42796ad1cf8cb23b004556cee5dea4821d0d5f.tar.gz
gcc: remove crosssdk from using fsl specific patches
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_4.6.bbappend1
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bbappend22
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk_4.6.bbappend1
-rw-r--r--recipes-devtools/gcc/gcc-fsl.inc2
-rw-r--r--recipes-devtools/gcc/gcc-runtime_4.6.bbappend1
5 files changed, 1 insertions, 26 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.6.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_4.6.bbappend
deleted file mode 100644
index 1c725f2..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.6.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gcc-fsl.inc
diff --git a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bbappend b/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bbappend
deleted file mode 100644
index ed27db0..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bbappend
+++ /dev/null
@@ -1,22 +0,0 @@
1require gcc-fsl.inc
2
3do_install () {
4 oe_runmake 'DESTDIR=${D}' install
5 install -d ${D}${target_base_libdir}/
6 cp -rf ${D}${exec_prefix}/${TARGET_SYS}/${baselib}/ ${D}${target_base_libdir}/
7
8 # We don't really need this (here shares/ contains man/, info/, locale/).
9 rm -rf ${D}${datadir}/
10
11 # We use libiberty from binutils
12 find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
13 find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
14
15 # Insert symlinks into libexec so when tools without a prefix are searched for, the correct ones are
16 # found. These need to be relative paths so they work in different locations.
17 dest=${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/
18 install -d $dest
19 for t in ar as ld nm objcopy objdump ranlib strip g77 gcc cpp gfortran; do
20 ln -sf ${BINRELPATH}/${TARGET_PREFIX}$t $dest$t
21 done
22}
diff --git a/recipes-devtools/gcc/gcc-crosssdk_4.6.bbappend b/recipes-devtools/gcc/gcc-crosssdk_4.6.bbappend
deleted file mode 100644
index 1c725f2..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk_4.6.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gcc-fsl.inc
diff --git a/recipes-devtools/gcc/gcc-fsl.inc b/recipes-devtools/gcc/gcc-fsl.inc
index 9e7c615..9e8cb31 100644
--- a/recipes-devtools/gcc/gcc-fsl.inc
+++ b/recipes-devtools/gcc/gcc-fsl.inc
@@ -43,4 +43,4 @@ SRC_URI_fsl = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};proto=http \
43 43
44FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 44FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
45 45
46PR_fsl .= "+${DISTRO}.2" 46PR_fsl .= "+${DISTRO}.3"
diff --git a/recipes-devtools/gcc/gcc-runtime_4.6.bbappend b/recipes-devtools/gcc/gcc-runtime_4.6.bbappend
deleted file mode 100644
index 1c725f2..0000000
--- a/recipes-devtools/gcc/gcc-runtime_4.6.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gcc-fsl.inc