summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-03-09 16:09:12 +0000
committerMatthew McClintock <msm@freescale.com>2012-03-14 16:43:43 -0500
commit7fe98088b5e56447e3de54d4dc4745e4fcc00e7b (patch)
treed0e3bda9b7e1f6d727ae0be7cfd1038664764c22 /recipes-devtools
parentcd8d01a52100e0a88c7c62ad0a7503ba9d9cb064 (diff)
downloadmeta-fsl-ppc-7fe98088b5e56447e3de54d4dc4745e4fcc00e7b.tar.gz
binutils: pull a patch from Yocto to fix path issue of libiberty
without the fix, following error appears when build native packages which require libierty.a: /usr/bin/ld: cannot find -liberty Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/binutils/binutils-fsl.inc3
-rw-r--r--recipes-devtools/binutils/files/libiberty_path_fix.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/recipes-devtools/binutils/binutils-fsl.inc b/recipes-devtools/binutils/binutils-fsl.inc
index e425d42..88b5eac 100644
--- a/recipes-devtools/binutils/binutils-fsl.inc
+++ b/recipes-devtools/binutils/binutils-fsl.inc
@@ -3,8 +3,9 @@ SRC_URI = "\
3 file://bin.e5500.patch \ 3 file://bin.e5500.patch \
4 file://bin.e6500-2.patch \ 4 file://bin.e6500-2.patch \
5 file://bin.e500mc_nop.patch \ 5 file://bin.e500mc_nop.patch \
6 file://libiberty_path_fix.patch \
6 " 7 "
7 8
8FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 9FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
9 10
10PR .= "+${DISTRO}.0" 11PR .= "+${DISTRO}.1"
diff --git a/recipes-devtools/binutils/files/libiberty_path_fix.patch b/recipes-devtools/binutils/files/libiberty_path_fix.patch
new file mode 100644
index 0000000..3772dfb
--- /dev/null
+++ b/recipes-devtools/binutils/files/libiberty_path_fix.patch
@@ -0,0 +1,22 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3don't let the distro compiler point to the wrong installation location
4
5Thanks to RP for helping find the source code causing the issue.
6
72010/08/13
8Nitin A Kamble <nitin.a.kamble@intel.com>
9Index: binutils-2.20.1/libiberty/Makefile.in
10===================================================================
11--- binutils-2.20.1.orig/libiberty/Makefile.in
12+++ binutils-2.20.1/libiberty/Makefile.in
13@@ -327,7 +327,8 @@ install: install_to_$(INSTALL_DEST) inst
14 # multilib-specific flags, it's overridden by FLAGS_TO_PASS from the
15 # default multilib, so we have to take CFLAGS into account as well,
16 # since it will be passed the multilib flags.
17-MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
18+#MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
19+MULTIOSDIR = ""
20 install_to_libdir: all
21 ${mkinstalldirs} $(DESTDIR)$(libdir)/$(MULTIOSDIR)
22 $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(MULTIOSDIR)/$(TARGETLIB)n