summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu_1.0.bb
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-03-08 15:28:29 +0000
committerMatthew McClintock <msm-oss@mcclintock.net>2013-03-08 17:58:14 -0600
commite699fcc24d25e4a09ff314922a857577a6909736 (patch)
tree844339b70b7aa774f7dcd81560d6d09a943990c3 /recipes-devtools/qemu/qemu_1.0.bb
parent443ec6e840d2e8036c16598124062196ee9fd7ed (diff)
downloadmeta-fsl-ppc-e699fcc24d25e4a09ff314922a857577a6909736.tar.gz
qemu: configure properly check if -lrt is needed
-lrt is needed to avoid the error "undefined reference to `timer_settime'". add the check in configure. Backport from http://git.qemu.org/?p=qemu.git commit: 8bacde8d86a09699207d85d4bab06162aed18dc4 Fix the below build issue: | ../qemu-timer.o: In function `dynticks_rearm_timer': | .../qemu/1.0+fsl-r2/git/qemu-timer.c:597: undefined reference to `timer_gettime' | .../qemu/1.0+fsl-r2/git/qemu-timer.c:610: undefined reference to `timer_settime' | ../qemu-timer.o: In function `dynticks_stop_timer': | .../qemu/1.0+fsl-r2/git/qemu-timer.c:583: undefined reference to `timer_delete' | ../qemu-timer.o: In function `dynticks_start_timer': | .../qemu/1.0+fsl-r2/git/qemu-timer.c:565: undefined reference to `timer_create' | ivshmem.o: In function `pci_ivshmem_init': | .../qemu/1.0+fsl-r2/git/hw/ivshmem.c:720: undefined reference to `shm_open' | .../qemu/1.0+fsl-r2/git/hw/ivshmem.c:727: undefined reference to `shm_open' | collect2: error: ld returned 1 exit status | make[1]: *** [qemu-system-ppc] Error 1 | make: *** [subdir-ppc-softmmu] Error 2 | ERROR: oe_runmake failed | ERROR: Function failed: do_compile Yocto 1.4_M4 uses qemu 1.3.1 which includes this fix. So this issue only appeared to us. Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-devtools/qemu/qemu_1.0.bb')
-rw-r--r--recipes-devtools/qemu/qemu_1.0.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-devtools/qemu/qemu_1.0.bb b/recipes-devtools/qemu/qemu_1.0.bb
index ff4afde..19efd9f 100644
--- a/recipes-devtools/qemu/qemu_1.0.bb
+++ b/recipes-devtools/qemu/qemu_1.0.bb
@@ -5,11 +5,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
5 5
6# This means v1.0 with FSL specific patches applied 6# This means v1.0 with FSL specific patches applied
7PV = "1.0+fsl" 7PV = "1.0+fsl"
8PR = "r2" 8PR = "r3"
9 9
10DEPENDS += "dtc" 10DEPENDS += "dtc"
11 11
12SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git" 12SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git \
13 file://0001-configure-properly-check-if-lrt-is-needed.patch \
14"
13SRCREV = "7feabd47a814214dc4bebfd97d0eaf30dc50a68f" 15SRCREV = "7feabd47a814214dc4bebfd97d0eaf30dc50a68f"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"