summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gcc/gcc-fsl.inc
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-03-09 10:57:35 +0000
committerMatthew McClintock <msm@freescale.com>2012-03-13 12:41:42 -0500
commit122c5bfdad95930de96e191aafb0304fded007b2 (patch)
treeea66cb9147fed9ceacd9eacd5913b10bb64734a1 /recipes-devtools/gcc/gcc-fsl.inc
parent4f2d99fbb0afd19376e404583700ee31428f7c2e (diff)
downloadmeta-fsl-ppc-122c5bfdad95930de96e191aafb0304fded007b2.tar.gz
integrate fsl toolchain patches
binutils: bin.e500mc_nop.patch bin.e5500.patch bin.e6500-2.patch eglibc: generate-supported.mk glibc.e500mc_subspecies_of_powerpc_is_not_supported.patch glibc.fixgcc4.6.patch glibc.fix_prof.patch glibc.fix_sqrt.patch glibc.readv_proto.patch glibc.undefined_static.patch gcc: gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch gcc.fix_longversionstring.patch gcc.rm_slow_tests.patch gcc.fix_mingw32.patch gcc.fix_cloogstatic2.patch gcc.fix_build-with-cxx.patch gcc.e6500-FSF46.patch gcc.ld_unaligned-460.patch gcc.local_unaligned_altivec.patch gcc.soft_float-460.patch gcc.case_values.patch gcc.builtin_isel.patch gcc.experimental_move.patch gcc.widen_types-46.patch gcc.extelim-v3.patch gcc.e5500_mfocr.patch gcc.opt-array-offset.patch gcc.load_on_store_bypass-462.patch gcc.fix_constvector.patch gcc.fix_MTWX51204-dwarf-vector-reg.patch gcc.fix_ira-loop-pressure.patch optional_libstdc.patch gcc.remove_CCUNSmode_reference.patch gcc.check_path_validity.patch gcc.fix_header_issue.patch gcc.fix_SSIZE_MAX_undefine_issue.patch gettext: gettext.fix_testcase.patch Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Diffstat (limited to 'recipes-devtools/gcc/gcc-fsl.inc')
-rw-r--r--recipes-devtools/gcc/gcc-fsl.inc44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-fsl.inc b/recipes-devtools/gcc/gcc-fsl.inc
new file mode 100644
index 0000000..83d519c
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-fsl.inc
@@ -0,0 +1,44 @@
1#LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
2# file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
3# file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
4# file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
5# file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8"
6
7BINV = "4.6.2"
8
9SRCREV = "180516"
10# ignore linaro backports since we are changing the SRCREV
11GCC-4_6-BRANCH-LINARO-BACKPORTS = ""
12
13SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};proto=http \
14 file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
15 file://gcc.fix_longversionstring.patch \
16 file://gcc.rm_slow_tests.patch \
17 file://gcc.fix_mingw32.patch \
18 file://gcc.fix_cloogstatic2.patch \
19 file://gcc.fix_build-with-cxx.patch \
20 file://gcc.e6500-FSF46.patch \
21 file://gcc.ld_unaligned-460.patch \
22 file://gcc.local_unaligned_altivec.patch \
23 file://gcc.soft_float-460.patch \
24 file://gcc.case_values.patch \
25 file://gcc.builtin_isel.patch \
26 file://gcc.experimental_move.patch \
27 file://gcc.widen_types-46.patch \
28 file://gcc.extelim-v3.patch \
29 file://gcc.e5500_mfocr.patch \
30 file://gcc.opt-array-offset.patch \
31 file://gcc.load_on_store_bypass-462.patch \
32 file://gcc.fix_constvector.patch \
33 file://gcc.fix_MTWX51204-dwarf-vector-reg.patch \
34 file://gcc.fix_ira-loop-pressure.patch \
35 file://optional_libstdc.patch \
36 file://gcc.remove_CCUNSmode_reference.patch \
37 file://gcc.check_path_validity.patch \
38 file://gcc.fix_header_issue.patch \
39 file://gcc.fix_SSIZE_MAX_undefine_issue.patch \
40"
41
42FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
43
44PR .= "+${DISTRO}.0"