summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-03-09 15:32:01 +0000
committerMatthew McClintock <msm-oss@mcclintock.net>2013-03-11 23:29:27 -0500
commite7d2ba01fbd087f4a6a46d59b501f2a3c6e215ad (patch)
treeca01b307218551b5c51306d0597936fb38ba5755 /recipes-core
parenta745325a19d359856eb4d77390e4e4cc69e5f415 (diff)
downloadmeta-fsl-ppc-e7d2ba01fbd087f4a6a46d59b501f2a3c6e215ad.tar.gz
udev-extraconf: move rules from udev and netbase
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/udev-extraconf/71-fsl-dpaa-persistent-networking.rules17
-rw-r--r--recipes-core/udev/udev-extraconf/local.rules42
-rw-r--r--recipes-core/udev/udev-extraconf_1.0.bbappend11
3 files changed, 70 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-extraconf/71-fsl-dpaa-persistent-networking.rules b/recipes-core/udev/udev-extraconf/71-fsl-dpaa-persistent-networking.rules
new file mode 100644
index 0000000..356c172
--- /dev/null
+++ b/recipes-core/udev/udev-extraconf/71-fsl-dpaa-persistent-networking.rules
@@ -0,0 +1,17 @@
1# Rules for handling naming the DPAA FMan ethernet ports in a consistent way
2SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4e0000", NAME="fm1-gb0"
3SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4e2000", NAME="fm1-gb1"
4SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4e4000", NAME="fm1-gb2"
5SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4e6000", NAME="fm1-gb3"
6SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4e8000", NAME="fm1-gb4"
7SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe4f0000", NAME="fm1-10g"
8SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5e0000", NAME="fm2-gb0"
9SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5e2000", NAME="fm2-gb1"
10SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5e4000", NAME="fm2-gb2"
11SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5e6000", NAME="fm2-gb3"
12SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5e8000", NAME="fm2-gb4"
13SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ffe5f0000", NAME="fm2-10g"
14
15# P1023 has its Fman @ different offsets
16SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ff7e0000", NAME="fm1-gb0"
17SUBSYSTEM=="net", DRIVERS=="fsl_dpa", ATTR{device_addr}=="ff7e2000", NAME="fm1-gb1"
diff --git a/recipes-core/udev/udev-extraconf/local.rules b/recipes-core/udev/udev-extraconf/local.rules
new file mode 100644
index 0000000..43034b8
--- /dev/null
+++ b/recipes-core/udev/udev-extraconf/local.rules
@@ -0,0 +1,42 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16KERNEL=="nbd*", GOTO="persistent_storage_end"
17
18SUBSYSTEM=="block", ENV{DEVTYPE}=="partition", GOTO="nomountblock"
19
20# Media automounting
21SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
22SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
23
24# Handle network interface setup
25SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
26SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
27
28# The first framebuffer is symlinked to /dev/fb
29KERNEL=="fb0", SYMLINK+="fb"
30
31# The first rtc device is symlinked to /dev/rtc
32KERNEL=="rtc0", SYMLINK+="rtc"
33
34# Try and modprobe for drivers for new hardware
35ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
36
37# Create a symlink to any touchscreen input device
38SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
39
40LABEL="persistent_storage_end"
41
42LABEL="nomountblock"
diff --git a/recipes-core/udev/udev-extraconf_1.0.bbappend b/recipes-core/udev/udev-extraconf_1.0.bbappend
new file mode 100644
index 0000000..3b66250
--- /dev/null
+++ b/recipes-core/udev/udev-extraconf_1.0.bbappend
@@ -0,0 +1,11 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 1}"
4
5SRC_URI_append = " file://71-fsl-dpaa-persistent-networking.rules"
6
7do_install_append () {
8 install -d ${D}${sysconfdir}/udev/rules.d/
9 install -m 0644 ${WORKDIR}/71-fsl-dpaa-persistent-networking.rules ${D}${sysconfdir}/udev/rules.d
10}
11