summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2014-08-01 12:33:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-08-06 11:07:40 +0800
commitcd5b8b145b57165e613b53cbbcff2acaf3d63582 (patch)
treeba78adfcab1fce9d8c3919edfa18e87314738401 /recipes-core
parent74c2a11244195a15652cb54139b9d775b41e2265 (diff)
downloadmeta-fsl-ppc-cd5b8b145b57165e613b53cbbcff2acaf3d63582.tar.gz
udev[-extraconf]: skip mmc rpmb partitions
In FSL SDK 1.6 Kernel, mmc driver has created a new partition with "mmcblkXrpmb" if device expresses it support of RPMB. RPMB (Replay Protected Memory Block), A signed access to a Replay Protected Memory Block is provided. This function provides means for the system to store data to the specific memory area in an authenticated and replay protected manner. In that case, any read/write access to this partition device will report errors which will not impact any fuction. add rules to skip it, avoid the below error msg: | mmcblk0rpmb: retrying using single block read | mmcblk0rpmb: error -110 transferring data Signed-off-by: Ting Liu <ting.liu@freescale.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend9
-rw-r--r--recipes-core/udev/udev/skip-rules-for-mmc-rpmb-partition.patch41
-rw-r--r--recipes-core/udev/udev_182.bbappend7
3 files changed, 53 insertions, 4 deletions
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index db74aac..6c2bfe2 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,10 +1,13 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2 2
3SRC_URI_append = " file://${@bb.utils.contains("TUNE_FEATURES", "e6500", \ 3SRC_URI_append_qoriq-ppc = " file://${@bb.utils.contains("TUNE_FEATURES", "e6500", \
4 "72-fsl-dpaa-persistent-networking.rules", "71-fsl-dpaa-persistent-networking.rules", d)}" 4 "72-fsl-dpaa-persistent-networking.rules", "71-fsl-dpaa-persistent-networking.rules", d)}"
5 5
6do_install_append () { 6do_install_append_qoriq-ppc () {
7 install -d ${D}${sysconfdir}/udev/rules.d/ 7 install -d ${D}${sysconfdir}/udev/rules.d/
8 install -m 0644 ${WORKDIR}/*-fsl-dpaa-persistent-networking.rules ${D}${sysconfdir}/udev/rules.d 8 install -m 0644 ${WORKDIR}/*-fsl-dpaa-persistent-networking.rules ${D}${sysconfdir}/udev/rules.d
9
10 # skip mmc rpmb partitions
11 echo "/dev/mmcblk.*rpmb" >>${D}${sysconfdir}/udev/mount.blacklist
9} 12}
10 13
diff --git a/recipes-core/udev/udev/skip-rules-for-mmc-rpmb-partition.patch b/recipes-core/udev/udev/skip-rules-for-mmc-rpmb-partition.patch
new file mode 100644
index 0000000..edbc0b3
--- /dev/null
+++ b/recipes-core/udev/udev/skip-rules-for-mmc-rpmb-partition.patch
@@ -0,0 +1,41 @@
1From 68a780f4cbba18c01d8409faafb1f7904afa86a9 Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@freescale.com>
3Date: Thu, 31 Jul 2014 16:12:32 +0800
4Subject: [PATCH] skip rules for mmc rpmb partition
5
6Upstream-status: Pending
7
8In FSL SDK 1.6 Kernel, mmc driver has created a new partition
9with "mmcblkXrpmb" if device expresses it support of RPMB.
10
11RPMB (Replay Protected Memory Block), A signed access to a Replay
12Protected Memory Block is provided. This function provides means
13for the system to store data to the specific memory area in an
14authenticated and replay protected manner.
15
16In that case, any read/write access to this partition device will
17report errors which will not impact any fuction.
18
19add rules to skip it.
20
21Signed-off-by: Ting Liu <ting.liu@freescale.com>
22---
23 rules/60-persistent-storage.rules | 2 +-
24 1 file changed, 1 insertion(+), 1 deletion(-)
25
26diff --git a/rules/60-persistent-storage.rules b/rules/60-persistent-storage.rules
27index fa687f2..bb3f8f9 100644
28--- a/rules/60-persistent-storage.rules
29+++ b/rules/60-persistent-storage.rules
30@@ -14,7 +14,7 @@ ACTION=="add", SUBSYSTEM=="module", KERNEL=="block", ATTR{parameters/events_dfl_
31 SUBSYSTEM!="block", GOTO="persistent_storage_end"
32
33 # skip rules for inappropriate block devices
34-KERNEL=="fd*|mtd*|nbd*|gnbd*|btibm*|dm-*|md*", GOTO="persistent_storage_end"
35+KERNEL=="fd*|mtd*|nbd*|gnbd*|btibm*|dm-*|md*|mmcblk*rpmb", GOTO="persistent_storage_end"
36
37 # ignore partitions that span the entire disk
38 TEST=="whole_disk", GOTO="persistent_storage_end"
39--
401.8.3.2
41
diff --git a/recipes-core/udev/udev_182.bbappend b/recipes-core/udev/udev_182.bbappend
index 72d991c..4eedfd8 100644
--- a/recipes-core/udev/udev_182.bbappend
+++ b/recipes-core/udev/udev_182.bbappend
@@ -1 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3SRC_URI_append_qoriq-ppc = " \
4 file://skip-rules-for-mmc-rpmb-partition.patch \
5"
6