summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorchunrong guo <b40290@freescale.com>2013-08-28 09:29:43 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-09-03 11:12:53 +0800
commit1ddf5e66c635e086864ce15931628ce1a2d6ff0a (patch)
treed82b68d97d92a8b026cece0d2f04d0e703ef7f4e /recipes-core
parent58a57096e4b7e2ceca3c33d3e7100c5434966cd9 (diff)
downloadmeta-fsl-ppc-1ddf5e66c635e086864ce15931628ce1a2d6ff0a.tar.gz
Revert "e500v2: workaround for ICE of gcc-4.8.x"
*This reverts commit 93c57323edc118eb8905980348ad3888664f2382 and commit efd344473c277eab8c1bae56120779983aba6176 *The reason for reverting this is: the below patch fix this problem. the patch url is : http://patches.openembedded.org/patch/56803/ Signed-off-by: Chunrong Guo <B40290@freescale.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/coreutils/coreutils_8.21.bbappend4
-rw-r--r--recipes-core/coreutils/files/coreutils-fix-dd-segfault-for-e500v2.patch37
2 files changed, 0 insertions, 41 deletions
diff --git a/recipes-core/coreutils/coreutils_8.21.bbappend b/recipes-core/coreutils/coreutils_8.21.bbappend
deleted file mode 100644
index 37d3ce2..0000000
--- a/recipes-core/coreutils/coreutils_8.21.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_e500v2 = " file://coreutils-fix-dd-segfault-for-e500v2.patch \
4"
diff --git a/recipes-core/coreutils/files/coreutils-fix-dd-segfault-for-e500v2.patch b/recipes-core/coreutils/files/coreutils-fix-dd-segfault-for-e500v2.patch
deleted file mode 100644
index dbeb9b2..0000000
--- a/recipes-core/coreutils/files/coreutils-fix-dd-segfault-for-e500v2.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1Upstream-Status: Pending
2
3Fix the segmentation fault issue when using dd on e500v2 targets,
4use %f instead of $Lf, since single-float is used for e500v2 due to
5an ICE of gcc-4.8.1.
6
7Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
8
9--- coreutils-8.21/lib/human.c.orig 2013-08-16 05:17:24.466225177 -0500
10+++ coreutils-8.21/lib/human.c 2013-08-16 05:17:52.007225123 -0500
11@@ -228,7 +228,7 @@
12
13 if (! (opts & human_autoscale))
14 {
15- sprintf (buf, "%.0Lf", adjust_value (inexact_style, damt));
16+ sprintf (buf, "%.0f", adjust_value (inexact_style, damt));
17 buflen = strlen (buf);
18 nonintegerlen = 0;
19 }
20@@ -246,7 +246,7 @@
21
22 damt /= e;
23
24- sprintf (buf, "%.1Lf", adjust_value (inexact_style, damt));
25+ sprintf (buf, "%.1f", adjust_value (inexact_style, damt));
26 buflen = strlen (buf);
27 nonintegerlen = decimal_pointlen + 1;
28
29@@ -254,7 +254,7 @@
30 || ((opts & human_suppress_point_zero)
31 && buf[buflen - 1] == '0'))
32 {
33- sprintf (buf, "%.0Lf",
34+ sprintf (buf, "%.0f",
35 adjust_value (inexact_style, damt * 10) / 10);
36 buflen = strlen (buf);
37 nonintegerlen = 0;