summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
diff options
context:
space:
mode:
authorCristian Stoica <cristian.stoica@freescale.com>2015-07-17 17:29:43 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:38:00 +0800
commitc0590434ae1571602fde9441f447a6fb35967e4c (patch)
treebd0bd8d2592651c8fd406e490e2a6d08a0cd6e44 /recipes-connectivity/openssl/openssl_1.0.1i.bbappend
parent1d729c77e7aadc0cb90cc4c1ad6401c38408899e (diff)
downloadmeta-fsl-ppc-c0590434ae1571602fde9441f447a6fb35967e4c.tar.gz
openssl: add sdk-v1.8 patches
The imports the following changes: eng_cryptodev: extend TLS offload with+ 3des_cbc_hmac_sha1 eng_cryptodev: add support for TLSv1.1 record offload eng_cryptodev: add support for TLSv1.2 record offload cryptodev: drop redundant function cryptodev: do not zero the buffer before use cryptodev: clean-up code layout cryptodev: do not cache file descriptor in 'open' cryptodev: put_dev_crypto should be an int cryptodev: simplify cryptodev pkc support code Signed-off-by: Cristian Stoica <cristian.stoica@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-connectivity/openssl/openssl_1.0.1i.bbappend')
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
index 2fa098f..7b381ff 100644
--- a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
+++ b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
@@ -19,7 +19,17 @@ SRC_URI_append_class-target = " file://0001-remove-double-initialization-of-cryp
19 file://0015-SW-Backoff-mechanism-for-dsa-keygen.patch \ 19 file://0015-SW-Backoff-mechanism-for-dsa-keygen.patch \
20 file://0016-Fixed-DH-keygen-pair-generator.patch \ 20 file://0016-Fixed-DH-keygen-pair-generator.patch \
21 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \ 21 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
22 file://0018-eng_cryptodev-extend-TLS-offload-with-3des_cbc_hmac_.patch \
23 file://0019-eng_cryptodev-add-support-for-TLSv1.1-record-offload.patch \
24 file://0020-eng_cryptodev-add-support-for-TLSv1.2-record-offload.patch \
25 file://0021-cryptodev-drop-redundant-function.patch \
26 file://0022-cryptodev-do-not-zero-the-buffer-before-use.patch \
27 file://0023-cryptodev-clean-up-code-layout.patch \
28 file://0024-cryptodev-do-not-cache-file-descriptor-in-open.patch \
29 file://0025-cryptodev-put_dev_crypto-should-be-an-int.patch \
30 file://0026-cryptodev-simplify-cryptodev-pkc-support-code.patch \
22" 31"
32
23# Digest offloading through cryptodev is not recommended because of the 33# Digest offloading through cryptodev is not recommended because of the
24# performance penalty of the Openssl engine interface. Openssl generates a huge 34# performance penalty of the Openssl engine interface. Openssl generates a huge
25# number of calls to digest functions for even a small amount of work data. 35# number of calls to digest functions for even a small amount of work data.