summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl_1.0.1g.bbappend
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-06-14 13:25:20 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-11 13:35:09 +0800
commit6153043bfeefce698a08231a2ed1a52e442574fc (patch)
tree4256e31a741a7d658f55cb7c2d64b50316b76ff0 /recipes-connectivity/openssl/openssl_1.0.1g.bbappend
parentc4524b65fbfdacbad625c749e191e8e62be6593c (diff)
downloadmeta-fsl-ppc-6153043bfeefce698a08231a2ed1a52e442574fc.tar.gz
openssl: use fsl maintained source
add bbappend to use fsl own openssl source code which was tested Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-connectivity/openssl/openssl_1.0.1g.bbappend')
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1g.bbappend59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1g.bbappend b/recipes-connectivity/openssl/openssl_1.0.1g.bbappend
new file mode 100644
index 0000000..f3e49ae
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl_1.0.1g.bbappend
@@ -0,0 +1,59 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/openssl-fsl"
2
3RDEPENDS_${PN}_class-target += "cryptodev-module"
4
5# base package is taken from Freescale repository
6SRCBRANCH = "OpenSSL_1_0_1-stable"
7SRC_URI = "git://git.openssl.org/openssl.git;branch=${SRCBRANCH} \
8 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
9 file://0002-ECC-Support-header-for-Cryptodev-Engine.patch \
10 file://0003-add-support-for-TLS-algorithms-offload.patch \
11 file://0004-Fixed-private-key-support-for-DH.patch \
12 file://0005-Fixed-private-key-support-for-DH.patch \
13 file://0006-Initial-support-for-PKC-in-cryptodev-engine.patch \
14 file://0007-Added-hwrng-dev-file-as-source-of-RNG.patch \
15 file://0008-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
16 file://0009-eng_cryptodev-extend-TLS-offload-with-new-algorithms.patch \
17 file://0010-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
18 file://0011-RSA-Keygen-Fix.patch \
19 file://0012-Removed-local-copy-of-curve_t-type.patch \
20 file://0013-Modulus-parameter-is-not-populated-by-dhparams.patch \
21 file://0014-SW-Backoff-mechanism-for-dsa-keygen.patch \
22 file://0015-Fixed-DH-keygen-pair-generator.patch \
23"
24SRCREV = "b2d951e4232d2f90168f9a3dd0b7df9ecf2d81a8"
25
26SRC_URI += "file://configure-targets.patch \
27 file://shared-libs.patch \
28 file://oe-ldflags.patch \
29 file://engines-install-in-libdir-ssl.patch \
30 file://openssl-fix-link.patch \
31 file://debian/version-script.patch \
32 file://debian/pic.patch \
33 file://debian/c_rehash-compat.patch \
34 file://debian/ca.patch \
35 file://debian/make-targets.patch \
36 file://debian/no-rpath.patch \
37 file://debian/man-dir.patch \
38 file://debian/man-section.patch \
39 file://debian/no-symbolic.patch \
40 file://debian/debian-targets.patch \
41 file://openssl_fix_for_x32.patch \
42 file://openssl-fix-doc.patch \
43 file://fix-cipher-des-ede3-cfb1.patch \
44 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
45 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
46 file://initial-aarch64-bits.patch \
47 file://find.pl \
48 file://openssl-fix-des.pod-error.patch \
49 "
50S = "${WORKDIR}/git"
51
52# Digest offloading through cryptodev is not recommended because of the
53# performance penalty of the Openssl engine interface. Openssl generates a huge
54# number of calls to digest functions for even a small amount of work data.
55# For example there are 70 calls to cipher code and over 10000 to digest code
56# when downloading only 10 files of 700 bytes each.
57# Do not build OpenSSL with cryptodev digest support until engine digest
58# interface gets some rework:
59CFLAG := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"