summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-01-17 17:33:38 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:46 +0800
commite2b581d29348628c6c78a95e55c24811657581f7 (patch)
tree426f40fe28fbb20b104c404e841c8fb74fa62c9c /recipes-bsp
parenta6c4175595b0f316e543cf93a8b6dc1a7f098997 (diff)
downloadmeta-fsl-ppc-e2b581d29348628c6c78a95e55c24811657581f7.tar.gz
u-boot: update to sdk v1.6 release
1.u-boot released in sdk v1.6 was based on 2014.01, set PV to 2014.01+fslgit 2.all the license files was put to Licenses/ directory now, update LIC_FILES_CHKSUM 3.not break if the u-boot config not supported 4.nand u-boot was named as u-boot-with-spl.bin, copy the right binary Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 406914c..ec744f5 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -2,18 +2,8 @@ DESCRIPTION = "U-boot bootloader"
2HOMEPAGE = "http://u-boot.sf.net" 2HOMEPAGE = "http://u-boot.sf.net"
3SECTION = "bootloaders" 3SECTION = "bootloaders"
4PROVIDES = "virtual/bootloader" 4PROVIDES = "virtual/bootloader"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 6LIC_FILES_CHKSUM = " \
7LICENSE_t2080qds = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
8LIC_FILES_CHKSUM_t2080qds = " \
9 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
11 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
12 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
13 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
14"
15LICENSE_t2080qds-64b = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
16LIC_FILES_CHKSUM_t2080qds-64b = " \
17 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 7 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
18 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \ 8 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
19 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \ 9 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
@@ -21,17 +11,14 @@ LIC_FILES_CHKSUM_t2080qds-64b = " \
21 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ 11 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
22" 12"
23 13
24PR = "r30" 14PV = "2014.01+fslgit"
25INHIBIT_DEFAULT_DEPS = "1" 15INHIBIT_DEFAULT_DEPS = "1"
26DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}" 16DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}"
27 17
28inherit deploy 18inherit deploy
29 19
30SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \ 20SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1"
31 file://Fix-the-depend-race-issue.patch" 21SRCREV = "fe1d4f5739e752ad45ada6227a9fb19590af7194"
32SRCREV = "5438fc1ca159c8f5724272efd1289e6d49771e69"
33SRCREV_t2080qds = "fc03874549668c1a10f97c10b3a77cb0f236df19"
34SRCREV_t2080qds-64b = "fc03874549668c1a10f97c10b3a77cb0f236df19"
35 22
36python () { 23python () {
37 if d.getVar("TCMODE", True) == "external-fsl": 24 if d.getVar("TCMODE", True) == "external-fsl":
@@ -84,6 +71,11 @@ do_compile () {
84 fi 71 fi
85 72
86 for board in ${UBOOT_MACHINES}; do 73 for board in ${UBOOT_MACHINES}; do
74 if ! grep -wq $board ${S}/boards.cfg;then
75 echo "WARNING: $board not supported in boards.cfg"
76 continue
77 fi
78
87 oe_runmake O=${board} distclean 79 oe_runmake O=${board} distclean
88 oe_runmake O=${board} ${board} 80 oe_runmake O=${board} ${board}
89 oe_runmake O=${board} all 81 oe_runmake O=${board} all
@@ -101,7 +93,7 @@ do_compile () {
101 if [ "x${UBOOT_TARGET}" != "x" ]; then 93 if [ "x${UBOOT_TARGET}" != "x" ]; then
102 # some boards' nand image was named as u-boot-with-spl 94 # some boards' nand image was named as u-boot-with-spl
103 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then 95 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then
104 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS|BSC913)";then 96 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS|BSC913|C293)";then
105 UBOOT_SOURCE=u-boot-with-spl 97 UBOOT_SOURCE=u-boot-with-spl
106 fi 98 fi
107 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then 99 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then
@@ -131,6 +123,10 @@ do_install(){
131 fi 123 fi
132 124
133 for board in ${UBOOT_MACHINES}; do 125 for board in ${UBOOT_MACHINES}; do
126 if ! grep -wq $board ${S}/boards.cfg;then
127 continue
128 fi
129
134 case "${board}" in 130 case "${board}" in
135 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 131 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
136 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 132 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
@@ -153,6 +149,10 @@ do_deploy(){
153 fi 149 fi
154 150
155 for board in ${UBOOT_MACHINES}; do 151 for board in ${UBOOT_MACHINES}; do
152 if ! grep -wq $board ${S}/boards.cfg;then
153 continue
154 fi
155
156 case "${board}" in 156 case "${board}" in
157 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 157 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
158 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 158 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;