summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-16 18:22:59 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-22 15:06:11 +0800
commitd89fa86d6f13146fce05f69a2f79cf129214021c (patch)
treefae4821d0ed38056b38ca4017b9968b931ad8d4b /recipes-bsp
parentb411fc8fba1debf1d4f7f628dd9fc15eff13cc13 (diff)
downloadmeta-fsl-ppc-d89fa86d6f13146fce05f69a2f79cf129214021c.tar.gz
u-boot: use TARGET_VENDOR to compose multilib sys
This aligns with the default setting in Poky. Signed-off-by: Ting Liu <ting.liu@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb b/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
index 43af42d..b780658 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
@@ -30,7 +30,7 @@ python () {
30 if "e5500-64b:" in arch or "e6500-64b:" in arch: 30 if "e5500-64b:" in arch or "e6500-64b:" in arch:
31 if not "lib32" in ml: 31 if not "lib32" in ml:
32 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 32 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
33 sys_multilib = 'powerpc-' + d.getVar('DISTRO') + 'mllib32-' + d.getVar('HOST_OS') 33 sys_multilib = 'powerpc' + d.getVar('TARGET_VENDOR') + 'mllib32-' + d.getVar('HOST_OS')
34 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') 34 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
35 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib) 35 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib)
36 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE")) 36 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE"))