summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-13 17:22:54 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-13 17:44:54 +0800
commitbd9f778ebb2569843ca472f2dfae5c715dff8968 (patch)
treef6f2714c852d8c32f55b928cfbe9be45c076e0bb /recipes-bsp
parent8cb984dab62831c82c05b9f2cd22d482acf699b4 (diff)
downloadmeta-fsl-ppc-bd9f778ebb2569843ca472f2dfae5c715dff8968.tar.gz
qe-ucode: install if QE_UCODE defined
* QE_UCODE definition is moved to <machine>.conf * add check if QE_UCODE defined in anonymous python function * install the binary into /boot Signed-off-by: Ting Liu <ting.liu@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb29
1 files changed, 13 insertions, 16 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index 06a7298..028d9bc 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -3,6 +3,13 @@ SECTION = "qe-ucode"
3LICENSE = "Freescale-EULA" 3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" 4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
5 5
6python () {
7 if not d.getVar("QE_UCODE", True):
8 machine = d.getVar("MACHINE", True)
9 raise bb.parse.SkipPackage("QE_UCODE not set in \
10 meta-fsl-ppc/conf/machine/%s.conf" % machine)
11}
12
6inherit deploy 13inherit deploy
7 14
8SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1" 15SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1"
@@ -11,28 +18,18 @@ SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c"
11S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
12 19
13do_install () { 20do_install () {
14 case ${MACHINE} in 21 install -d ${D}/boot
15 p1025rdb|p1021rdb|p1025twr) QE_UCODE="fsl_qe_ucode_1021_10_A.bin";; 22 install -m 644 ${QE_UCODE} ${D}/boot/
16 t1040rdb|t1040rdb-64b) QE_UCODE="iram_Type_A_T1040_r1.0.bin";;
17 *) QE_UCODE="";;
18 esac
19 install -d ${D}/
20 install -m 644 ${QE_UCODE} ${D}/
21} 23}
22 24
23do_deploy () { 25do_deploy () {
24 case ${MACHINE} in 26 install -d ${DEPLOYDIR}/boot
25 p1025rdb|p1021rdb|p1025twr) QE_UCODE="fsl_qe_ucode_1021_10_A.bin";; 27 install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot/
26 t1040rdb|t1040rdb-64b) QE_UCODE="iram_Type_A_T1040_r1.0.bin";;
27 *) QE_UCODE="";;
28 esac
29 install -d ${DEPLOYDIR}/
30 install -m 644 ${QE_UCODE} ${DEPLOYDIR}/
31} 28}
32addtask deploy before do_build after do_install 29addtask deploy before do_build after do_install
33 30
34PACKAGES += "${PN}-image" 31PACKAGES += "${PN}-image"
35FILES_${PN}-image += "/*" 32FILES_${PN}-image += "/boot/*"
36ALLOW_EMPTY_${PN} = "1" 33ALLOW_EMPTY_${PN} = "1"
37COMPATIBLE_MACHINE = "(p1025rdb|p1021rdb|p1025twr|t1040rdb|t1040rdb-64b)" 34COMPATIBLE_MACHINE = "(p1021rdb|p1025twr|t1)"
38 35