summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-09-03 10:50:31 -0700
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-09-09 17:17:19 +0800
commit7d31e66602c8029727d9082b18a690dfd7d07602 (patch)
tree9b88f70dac89bdd4156a705ab0d47e8c73ebcc5a /recipes-bsp
parentd953212ae5936a7d969d13801b0c2c1eb65cee6f (diff)
downloadmeta-fsl-ppc-7d31e66602c8029727d9082b18a690dfd7d07602.tar.gz
boot-format: obey CFLAGS, LDFLAGS
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/boot-format/boot-format/flags.patch21
-rw-r--r--recipes-bsp/boot-format/boot-format_git.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/recipes-bsp/boot-format/boot-format/flags.patch b/recipes-bsp/boot-format/boot-format/flags.patch
new file mode 100644
index 0000000..cddb34c
--- /dev/null
+++ b/recipes-bsp/boot-format/boot-format/flags.patch
@@ -0,0 +1,21 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -3,14 +3,14 @@
6 INSTALL=install
7 PREFIX=/usr
8
9-CFLAGS=-Wall
10+override CFLAGS+=-Wall
11
12 all: boot_format
13
14 boot_format.o: boot_format.c boot_format.h
15
16 boot_format: boot_format.o
17- $(CC) $< -o $@
18+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
19
20 install: boot_format
21 $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
diff --git a/recipes-bsp/boot-format/boot-format_git.bb b/recipes-bsp/boot-format/boot-format_git.bb
index eb7c6de..2d9f9b1 100644
--- a/recipes-bsp/boot-format/boot-format_git.bb
+++ b/recipes-bsp/boot-format/boot-format_git.bb
@@ -3,11 +3,12 @@ LICENSE = "GPLv2"
3PR = "r6" 3PR = "r6"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5 5
6SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1" 6SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1 \
7 file://flags.patch"
7SRCREV = "4eb81a6797ef4e58bf7d9b2d58afb37a21c1f550" 8SRCREV = "4eb81a6797ef4e58bf7d9b2d58afb37a21c1f550"
8 9
9S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
10EXTRA_OEMAKE = 'CC="${CC}"' 11EXTRA_OEMAKE = 'CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"'
11 12
12do_install(){ 13do_install(){
13 oe_runmake DESTDIR=${D} PREFIX=${prefix} install 14 oe_runmake DESTDIR=${D} PREFIX=${prefix} install