summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-05 18:32:21 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-07 10:12:52 +0800
commit6f23136ef1a2df48d80527afe52b2de0535c56a8 (patch)
treecbb6f2d34d931800bf30b1ed113af3cc99622818 /recipes-bsp
parent999651a453e1a57771ff0213375bc0fb784fd6a2 (diff)
downloadmeta-fsl-ppc-6f23136ef1a2df48d80527afe52b2de0535c56a8.tar.gz
u-boot: upgrade to 2014.07 with revision 659b6a2
This updates u-boot to sdk v1.7 release which was based on 2014.07. For detailed changes, see: http://git.freescale.com/git/cgit.cgi/ppc/sdk/u-boot.git/ Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2014.01.bb)42
1 files changed, 28 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2014.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
index e16438f..4a1b908 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2014.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
@@ -11,14 +11,14 @@ LIC_FILES_CHKSUM = " \
11 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ 11 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
12" 12"
13 13
14PV = "2014.01+fslgit" 14PV = "2014.07+fslgit"
15INHIBIT_DEFAULT_DEPS = "1" 15INHIBIT_DEFAULT_DEPS = "1"
16DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}" 16DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}"
17 17
18inherit deploy 18inherit deploy
19 19
20SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1" 20SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1"
21SRCREV = "fe1d4f5739e752ad45ada6227a9fb19590af7194" 21SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1"
22 22
23python () { 23python () {
24 if d.getVar("TCMODE", True) == "external-fsl": 24 if d.getVar("TCMODE", True) == "external-fsl":
@@ -77,7 +77,7 @@ do_compile () {
77 fi 77 fi
78 78
79 oe_runmake O=${board} distclean 79 oe_runmake O=${board} distclean
80 oe_runmake O=${board} ${board} 80 oe_runmake O=${board} ${board}_config
81 oe_runmake O=${board} all 81 oe_runmake O=${board} all
82 82
83 case "${board}" in 83 case "${board}" in
@@ -89,29 +89,43 @@ do_compile () {
89 esac 89 esac
90 90
91 # deal with sd/spi/nand/srio image 91 # deal with sd/spi/nand/srio image
92 UBOOT_SOURCE=u-boot 92 UBOOT_SOURCE=u-boot.bin
93 if [ "x${UBOOT_TARGET}" != "x" ]; then 93 if [ "x${UBOOT_TARGET}" != "x" ] && echo $board |egrep -qi "SECBOOT|SECURE"; then
94 # some boards' nand image was named as u-boot-with-spl 94 cp ${S}/${board}/${UBOOT_SOURCE} ${S}/${board}/${UBOOT_TARGET}.bin
95 elif [ "x${UBOOT_TARGET}" != "x" ]; then
96 # some boards' final binary was not named as u-boot.bin
95 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then 97 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then
96 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS|BSC913|C293)";then 98 if echo $board |egrep -q "^(BSC|C29|P10|P2020RDB)";then
97 UBOOT_SOURCE=u-boot-with-spl 99 UBOOT_SOURCE=u-boot-with-spl.bin
100 elif echo $board |egrep -q "^(B4|T1|T2|T4)";then
101 UBOOT_SOURCE=u-boot-with-spl-pbl.bin
102 elif echo $board |egrep -q "^(P2041|P3|P4|P5)";then
103 UBOOT_SOURCE=u-boot.pbl
98 fi 104 fi
99 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then 105 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then
100 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS)";then 106 if echo $board |egrep -q "^(P10|P2020RDB)";then
101 UBOOT_SOURCE=u-boot-with-spl 107 UBOOT_SOURCE=u-boot-with-spl.bin
108 elif echo $board |egrep -q "^(T1|T2)";then
109 UBOOT_SOURCE=u-boot-with-spl-pbl.bin
110 elif echo $board |egrep -q "^(B4|P2041|P3|P4|P5|T4)";then
111 UBOOT_SOURCE=u-boot.pbl
102 fi 112 fi
103 elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then 113 elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then
104 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS)";then 114 if echo $board |egrep -q "^(P10|P2020RDB)";then
105 UBOOT_SOURCE=u-boot-with-spl 115 UBOOT_SOURCE=u-boot-with-spl.bin
116 elif echo $board |egrep -q "^(B4|T1|T2|T4)";then
117 UBOOT_SOURCE=u-boot-with-spl-pbl.bin
118 elif echo $board |egrep -q "^(P2041|P3|P4|P5)";then
119 UBOOT_SOURCE=u-boot.pbl
106 fi 120 fi
107 fi 121 fi
108 cp ${S}/${board}/${UBOOT_SOURCE}.bin ${S}/${board}/${UBOOT_TARGET}.bin 122 cp ${S}/${board}/${UBOOT_SOURCE} ${S}/${board}/${UBOOT_TARGET}.bin
109 123
110 # use boot-format to regenerate spi image if BOOTFORMAT_CONFIG is not empty 124 # use boot-format to regenerate spi image if BOOTFORMAT_CONFIG is not empty
111 if [ "${UBOOT_TARGET}" = "u-boot-spi" ] && [ -n "${BOOTFORMAT_CONFIG}" ];then 125 if [ "${UBOOT_TARGET}" = "u-boot-spi" ] && [ -n "${BOOTFORMAT_CONFIG}" ];then
112 ${STAGING_BINDIR_NATIVE}/boot_format \ 126 ${STAGING_BINDIR_NATIVE}/boot_format \
113 ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \ 127 ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \
114 ${S}/${board}/${UBOOT_SOURCE}.bin -spi ${S}/${board}/${UBOOT_TARGET}.bin 128 ${S}/${board}/${UBOOT_SOURCE} -spi ${S}/${board}/${UBOOT_TARGET}.bin
115 fi 129 fi
116 fi 130 fi
117 done 131 done