summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-06-14 12:48:01 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:46 +0800
commit5c852741484295c6794548d51ed8491a005c587e (patch)
tree5aaf902f7ba1eb8de9747b7aeff8898b0b108541 /recipes-bsp
parent3ef77aa877a902d9e3f191e37c1e577607236af7 (diff)
downloadmeta-fsl-ppc-5c852741484295c6794548d51ed8491a005c587e.tar.gz
add recipes for ipc kernel module and userspace tool
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ipc/ipc-modules-multi_git.bb11
-rw-r--r--recipes-bsp/ipc/ipc-modules-single_git.bb11
-rw-r--r--recipes-bsp/ipc/ipc-modules.inc39
-rw-r--r--recipes-bsp/ipc/ipc-ust_git.bb50
-rw-r--r--recipes-bsp/ipc/ipc.inc7
5 files changed, 118 insertions, 0 deletions
diff --git a/recipes-bsp/ipc/ipc-modules-multi_git.bb b/recipes-bsp/ipc/ipc-modules-multi_git.bb
new file mode 100644
index 0000000..e5dc115
--- /dev/null
+++ b/recipes-bsp/ipc/ipc-modules-multi_git.bb
@@ -0,0 +1,11 @@
1require ipc-modules.inc
2
3EXTRA_OEMAKE ="KERNEL_DIR=${STAGING_KERNEL_DIR} ${SOC}=1 CONFIG_MULTI_RAT=1"
4
5do_install(){
6 install -d ${D}/usr/driver/IPC/multi_rat
7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/multi_rat
8}
9
10FILES_${PN} += "/usr/driver/IPC/multi_rat/*.ko"
11FILES_${PN}-dbg += "/usr/driver/IPC/multi_rat/.debug"
diff --git a/recipes-bsp/ipc/ipc-modules-single_git.bb b/recipes-bsp/ipc/ipc-modules-single_git.bb
new file mode 100644
index 0000000..03817e0
--- /dev/null
+++ b/recipes-bsp/ipc/ipc-modules-single_git.bb
@@ -0,0 +1,11 @@
1require ipc-modules.inc
2
3EXTRA_OEMAKE ="KERNEL_DIR=${STAGING_KERNEL_DIR} ${SOC}=1"
4
5do_install(){
6 install -d ${D}/usr/driver/IPC/single_rat
7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/single_rat
8}
9
10FILES_${PN} += "/usr/driver/IPC/single_rat/*.ko"
11FILES_${PN}-dbg += "/usr/driver/IPC/single_rat/.debug"
diff --git a/recipes-bsp/ipc/ipc-modules.inc b/recipes-bsp/ipc/ipc-modules.inc
new file mode 100644
index 0000000..015a91b
--- /dev/null
+++ b/recipes-bsp/ipc/ipc-modules.inc
@@ -0,0 +1,39 @@
1SUMMARY = "Linux IPC KERNEL MODULE "
2DESCRIPTION = "DSP boot application and ipc test application"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5
6require ipc.inc
7
8inherit module
9
10S = "${WORKDIR}/git"
11python () {
12 ma = d.getVar("DISTRO_FEATURES", True)
13 arch = d.getVar("OVERRIDES", True)
14
15 # the : after the arch is to skip the message on 64b
16 if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch):
17 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
18
19 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
20
21 if promote_kernel == "1":
22 d.setVar('KERNEL_CC_append', ' -m64')
23 d.setVar('KERNEL_LD_append', ' -melf64ppc')
24
25 error_qa = d.getVar('ERROR_QA', True)
26 if 'arch' in error_qa:
27 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
28}
29
30do_compile_prepend () {
31 cd ${S}/kernel
32 case ${MACHINE} in
33 bsc9132qds|bsc9131rdb) SOC=B913x;;
34 b4860qds|b4420qds) SOC=B4860;;
35 esac
36}
37
38INHIBIT_PACKAGE_STRIP = "1"
39
diff --git a/recipes-bsp/ipc/ipc-ust_git.bb b/recipes-bsp/ipc/ipc-ust_git.bb
new file mode 100644
index 0000000..c6b3cfe
--- /dev/null
+++ b/recipes-bsp/ipc/ipc-ust_git.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Linux IPC Userspace Tool"
2DESCRIPTION = "DSP boot application and ipc test application"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5
6require ipc.inc
7
8S = "${WORKDIR}/git"
9
10# workaround for issue of parallel build, required a actual fix in ipc source
11PARALLEL_MAKE = ""
12
13EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}"'
14
15do_compile () {
16 case ${MACHINE} in
17 bsc9132qds|bsc9131rdb) SOC=B913x;;
18 b4860qds|b4420qds|b4860qds-64b) SOC=B4860;;
19 esac
20 oe_runmake ${SOC}=1
21}
22
23do_install () {
24 install -d ${D}${bindir}
25 install -d ${D}${includedir}
26 install -d ${D}/ipc
27 install -m 755 ${S}/dsp_boot/dsp_bt ${D}/ipc
28 install -m 755 ${S}/ipc/ipc_test ${D}/ipc
29 install -m 755 ${S}/ipc/ipc_test67 ${D}/ipc
30 install -m 755 ${S}/ipc/l1d_app ${D}/ipc
31 install -m 755 ${S}/fsl_shm/app ${D}${bindir}/lg_shm_test
32 install -d ${D}${base_libdir}
33 install -m 755 ${S}/ipc/libipc.so ${D}${base_libdir}
34 install -m 755 ${S}/ipc/libmem.so ${D}${base_libdir}
35 install -m 755 ${S}/ipc/libdspboot.so ${D}${base_libdir}
36 install -d ${D}${includedir}/ipc
37 install -d ${D}${includedir}/ipc/ipc/include
38 install -d ${D}${includedir}/ipc/fsl_shm/lib
39 install ${S}/ipc/include/*.h ${D}${includedir}/ipc/ipc/include
40 install ${S}/dsp_boot/*.h ${D}${includedir}/ipc/ipc/include
41 install ${S}/kernel/fsl_ipc_types.h ${D}${includedir}/ipc/ipc/include
42 install ${S}/kernel/fsl_heterogeneous_common.h ${D}${includedir}/ipc/ipc/include
43 install ${S}/kernel/fsl_heterogeneous_l1_defense.h ${D}${includedir}/ipc/ipc/include
44 install ${S}/fsl_shm/include/*.h ${D}${includedir}/ipc/ipc/include
45 install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib
46}
47
48FILES_${PN} += "/ipc/*"
49FILES_${PN}-dbg += "/ipc/.debug"
50
diff --git a/recipes-bsp/ipc/ipc.inc b/recipes-bsp/ipc/ipc.inc
new file mode 100644
index 0000000..22ab1e3
--- /dev/null
+++ b/recipes-bsp/ipc/ipc.inc
@@ -0,0 +1,7 @@
1DEPENDS = "virtual/kernel"
2
3SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;nobranch=1"
4SRCREV = "7e36edbbc5ac5271c85d45745b3e70f47771f262"
5
6COMPATIBLE_MACHINE = "(bsc9132qds|bsc9131rdb|b4860qds|b4420qds)"
7