summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-06 13:00:43 +0000
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-02-18 13:17:54 +0800
commit2e9b383ccaf495b7d07dcc5065a6fa83fc03e501 (patch)
tree93f18b959dcbcbb9d44bb39b6d427c0821b9adaa /recipes-bsp
parentcb8d8ffd03645f58b530cc62e9a943a7bf93476c (diff)
downloadmeta-fsl-ppc-2e9b383ccaf495b7d07dcc5065a6fa83fc03e501.tar.gz
classes/u-boot: Update getVar syntax
This runs: sed -e 's:\(\.getVar([^,()]*\)):\1, False):g' -i `grep -ril getVar *` on the layer to update the getVar usages without an expand parameter, This ensures the layer continues to work with bitbake master. There is no functionality change although some of these sites may benefit from expand=True. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
index 7b942c7..172c757 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
@@ -37,10 +37,10 @@ python () {
37 if "e5500-64b:" in arch or "e6500-64b:" in arch: 37 if "e5500-64b:" in arch or "e6500-64b:" in arch:
38 if not "lib32" in ml: 38 if not "lib32" in ml:
39 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 39 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
40 sys_multilib = 'powerpc' + d.getVar('TARGET_VENDOR') + 'mllib32-' + d.getVar('HOST_OS') 40 sys_multilib = 'powerpc' + d.getVar('TARGET_VENDOR', False) + 'mllib32-' + d.getVar('HOST_OS', False)
41 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') 41 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
42 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib) 42 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE', False) + '/' + sys_multilib)
43 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE")) 43 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE", False))
44 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-') 44 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-')
45} 45}
46 46