summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-02-21 15:13:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:46 +0800
commit14b95789762c29f9893ec8043b7e4f77a5d9db64 (patch)
tree3d1c22ccc94e88204faa4e216cd1632a809a5b86 /recipes-bsp
parent3bbd20efe78515951f35f3453b626de2eb6bf53a (diff)
downloadmeta-fsl-ppc-14b95789762c29f9893ec8043b7e4f77a5d9db64.tar.gz
rcw: update to sdk v1.6 release
add support for new added boards Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb26
1 files changed, 15 insertions, 11 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index ad961ed..5e751b8 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -12,26 +12,30 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
12inherit deploy 12inherit deploy
13 13
14SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;nobranch=1" 14SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;nobranch=1"
15SRCREV = "bc38737b5cb08336a075cb38481881f87b33b7a1" 15SRCREV = "261b2355e9936ecb37b61e6f58dfc48dcfb805b3"
16SRCREV_t2080qds = "a694a89f4b57ce700b5b2ea84302c8618ece2f0f"
17SRCREV_t2080qds-64b = "a694a89f4b57ce700b5b2ea84302c8618ece2f0f"
18 16
19S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
20 18
21export PYTHON 19export PYTHON
22 20
23do_install () { 21do_install () {
24 make install 22 make install
25 23
26 M=`echo ${MACHINE} | sed s/-64b//g` 24 M=`echo ${MACHINE} | sed s/-64b//g`
27 install -d ${D}/boot/rcw 25 if [ "t1042rdb" = "${M}" ];then
28 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw 26 M=${M}_pi
27 fi
28 install -d ${D}/boot/rcw
29 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
29} 30}
30 31
31do_deploy () { 32do_deploy () {
32 M=`echo ${MACHINE} | sed s/-64b//g` 33 M=`echo ${MACHINE} | sed s/-64b//g`
33 install -d ${DEPLOYDIR}/rcw 34 if [ "t1042rdb" = "${M}" ];then
34 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw 35 M=${M}_pi
36 fi
37 install -d ${DEPLOYDIR}/rcw
38 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw
35} 39}
36addtask deploy after do_install 40addtask deploy after do_install
37 41