summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-10-29 14:21:04 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-01-12 18:06:01 +0800
commitc512e0442fc9c044fa945cc5bae612579f2c6393 (patch)
tree52f8008447544e4b3a0ddd239d4e07463e52acf9 /recipes-bsp/u-boot
parentd4888b46bf3fd312e5c44f7f3e9022c55642e699 (diff)
downloadmeta-fsl-ppc-c512e0442fc9c044fa945cc5bae612579f2c6393.tar.gz
u-boot: use spl version for sd and spi image
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index bfd2d79..2b6f1a0 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -85,6 +85,14 @@ do_compile () {
85 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB|BSC913)";then 85 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB|BSC913)";then
86 UBOOT_SOURCE=u-boot-with-spl 86 UBOOT_SOURCE=u-boot-with-spl
87 fi 87 fi
88 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then
89 if echo $board |egrep -q "(P1020RDB|P1021RDB|P2020RDB|P1022DS)";then
90 UBOOT_SOURCE=u-boot-with-spl
91 fi
92 elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then
93 if echo $board |egrep -q "(P1020RDB|P1021RDB|P2020RDB|P1022DS)";then
94 UBOOT_SOURCE=u-boot-with-spl
95 fi
88 fi 96 fi
89 cp ${S}/${board}/${UBOOT_SOURCE}.bin ${S}/${board}/${UBOOT_TARGET}.bin 97 cp ${S}/${board}/${UBOOT_SOURCE}.bin ${S}/${board}/${UBOOT_TARGET}.bin
90 98