summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorZongchun Yu <Zongchun.Yu@freescale.com>2013-11-28 14:30:13 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-02-13 11:24:51 +0800
commit83472a9b40529c75c3f5e5b0bcd0c7077024d741 (patch)
tree6d14bb03cd7b7e977450b271105d121d4068dcf7 /recipes-bsp/u-boot
parent09695b98c14f5f361fb14ad7c78c80a1540b7d20 (diff)
downloadmeta-fsl-ppc-83472a9b40529c75c3f5e5b0bcd0c7077024d741.tar.gz
u-boot:add srio image support
Signed-off-by: Zongchun Yu <Zongchun.Yu@freescale.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 4f1c61f..3939ef7 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -74,10 +74,11 @@ do_compile () {
74 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 74 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
75 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 75 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
76 *NAND*) UBOOT_TARGET="u-boot-nand";; 76 *NAND*) UBOOT_TARGET="u-boot-nand";;
77 *SRIO*) UBOOT_TARGET="u-boot-srio";;
77 *) UBOOT_TARGET="";; 78 *) UBOOT_TARGET="";;
78 esac 79 esac
79 80
80 # deal with sd/spi/nand image 81 # deal with sd/spi/nand/srio image
81 UBOOT_SOURCE=u-boot 82 UBOOT_SOURCE=u-boot
82 if [ "x${UBOOT_TARGET}" != "x" ]; then 83 if [ "x${UBOOT_TARGET}" != "x" ]; then
83 # some boards' nand image was named as u-boot-with-spl 84 # some boards' nand image was named as u-boot-with-spl
@@ -116,6 +117,7 @@ do_install(){
116 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 117 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
117 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 118 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
118 *NAND*) UBOOT_TARGET="u-boot-nand";; 119 *NAND*) UBOOT_TARGET="u-boot-nand";;
120 *SRIO*) UBOOT_TARGET="u-boot-srio";;
119 *) UBOOT_TARGET="u-boot";; 121 *) UBOOT_TARGET="u-boot";;
120 esac 122 esac
121 123
@@ -137,6 +139,7 @@ do_deploy(){
137 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 139 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
138 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 140 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
139 *NAND*) UBOOT_TARGET="u-boot-nand";; 141 *NAND*) UBOOT_TARGET="u-boot-nand";;
142 *SRIO*) UBOOT_TARGET="u-boot-srio";;
140 *) UBOOT_TARGET="u-boot";; 143 *) UBOOT_TARGET="u-boot";;
141 esac 144 esac
142 145