summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamelia Groza <camelia.groza@freescale.com>2016-03-15 15:04:04 +0200
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:14 +0800
commite50a010c327704857df63666ce3f3b17bf1b2805 (patch)
treea1697d3798b85ae763b86b682f2e50b0c999be18
parent5b6d16dcf61f653fcd7faf6d19192d139da31b5c (diff)
downloadmeta-fsl-ppc-e50a010c327704857df63666ce3f3b17bf1b2805.tar.gz
ceetm: update to a237e09
Changelog: a237e09 ceetm: qcount and qweight aren't mandatory; update the help message 09fd87e ceetm: change the qweight for wbfs classes at runtime 09d6bc7 ceetm: remove the ceetm kernel module fd9c4b3 ceetm: update class statistics 92c37a4 ceetm: edit the help message d155fd6 ceetm: configure the cr and er of prio classes 610e157 ceetm: separate print_opt into two calls 3a35a3c ceetm: configure the wbfs weight 3b2fdd0 ceetm: show wbfs classes 8b42626 ceetm: add the wbfs qdisc e9deb04 ceetm: merge the qdisc and class types; allow rates equal to 0 e45fc61 Configure the channels in the root classes 0eb7c9b Print a prio class 270c21b ceetm: configure the prio qdisc f272dbe ceetm: configure the root qdisc and the underlying classes fa07c93 ceetm: update the qdisc's help messages 1adfe00 ceetm: obtain the port's subportal dynamically * update the compatible machine list * no kernel module needs to be installed add ls1043 to the compatible machine list Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 144fe78..288de5d 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -2,26 +2,19 @@ DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD" 2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4 4
5DEPENDS="virtual/kernel" 5SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v2.0.x"
6 6SRCREV = "a237e094c3316a55727b855d15480e664545316a"
7inherit module qoriq_build_64bit_kernel
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v1.9.x"
10SRCREV = "2c79d0b3465368a19bb2b4ccd680ddd297ebe377"
11 7
12S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
13 9
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" 10EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16 11
17do_configure[depends] += "virtual/kernel:do_shared_workdir"
18do_install(){ 12do_install(){
19 install -d ${D}/lib/modules/${KERNEL_VERSION}/extra
20 mkdir -p ${D}/${libdir}/tc 13 mkdir -p ${D}/${libdir}/tc
21 install -m 644 ${S}/bin/ceetm.ko ${D}/lib/modules/${KERNEL_VERSION}/extra/
22 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/ 14 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/
23} 15}
24 16
25FILES_${PN} += "${libdir}/tc" 17FILES_${PN} += "${libdir}/tc"
26INHIBIT_PACKAGE_STRIP = "1" 18INHIBIT_PACKAGE_STRIP = "1"
27COMPATIBLE_MACHINE = "(e6500-64b|t1040|t1042)" 19COMPATIBLE_MACHINE = "(e6500-64b|t1040|t1042)"
20COMPATIBLE_MACHINE = "(b4|t1|t2|t4)"