summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2012-12-14 20:18:13 +0000
committerMatthew McClintock <msm@freescale.com>2013-01-30 17:11:01 -0600
commite383e093512e4565f55529163d4bde816acaa437 (patch)
treecfa85632248e934086c42a4542295bafd1608c03
parentd33832a4a9d053d899716520a322689584a89e30 (diff)
downloadmeta-fsl-ppc-e383e093512e4565f55529163d4bde816acaa437.tar.gz
usdpaa: add recipe
use external git tree to build usdpaa for t4/b4 Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r--recipes-tools/usdpaa/usdpaa_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-tools/usdpaa/usdpaa_git.bb b/recipes-tools/usdpaa/usdpaa_git.bb
new file mode 100644
index 0000000..697bead
--- /dev/null
+++ b/recipes-tools/usdpaa/usdpaa_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "User-Space Data-Path Acceleration Architecture drivers"
2SECTION = "usdpaa"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
5
6inherit pkgconfig
7
8DEPENDS = "libxml2 libedit ncurses readline flib"
9RDEPENDS_${PN} = "libgcc"
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git"
12SRCREV = "53c621f783c9d10d46828854120a3ebd58389779"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = 'V=1 CC="${CC}" LD="${LD}" AR="${AR}"'
17
18do_compile_prepend () {
19 export ARCH=${TARGET_ARCH}
20 export LIBXML2_CFLAGS="$(pkg-config --cflags libxml-2.0)"
21 export LIBXML2_LDFLAGS="$(pkg-config --libs --static libxml-2.0)"
22 export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
23 export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
24}
25
26do_install () {
27 oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D}
28}
29
30PARALLEL_MAKE_pn-${PN} = ""
31
32FILES_${PN} += "/root/SOURCE_THIS /usr/etc/"
33RDEPENDS_${PN} += "bash"