summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-10-16 06:03:57 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-10-17 11:28:41 +0800
commitcd26eb8dbbc3fb29dfb165599400d1771a54b03b (patch)
tree5d436e8f6f6e086397f76706e63a204706d143e1
parentb85c861c9b869e47adcbe1bb521b6d84cad394b1 (diff)
downloadmeta-fsl-ppc-cd26eb8dbbc3fb29dfb165599400d1771a54b03b.tar.gz
linux-qoriq-sdk : add config fragments
Signed-off-by: Chunrong Guo <B40290@freescale.com>
-rw-r--r--recipes-kernel/linux/linux-qoriq-sdk.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-sdk.bb b/recipes-kernel/linux/linux-qoriq-sdk.bb
index 7dd7059..b7ca721 100644
--- a/recipes-kernel/linux/linux-qoriq-sdk.bb
+++ b/recipes-kernel/linux/linux-qoriq-sdk.bb
@@ -11,13 +11,18 @@ SRC_URI += "file://libtraceevent-Remove-hard-coded-include-to-usr-local-include-
11 11
12PR = "${INC_PR}.1" 12PR = "${INC_PR}.1"
13 13
14DEPENDS_append = " libgcc" 14DEPENDS_append = " libgcc kern-tools-native"
15KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" 15KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
16KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" 16KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
17 17
18do_configure_prepend() { 18do_configure_prepend() {
19 # copy desired defconfig so we pick it up for the real kernel_do_configure 19 # copy desired defconfig so we pick it up for the real kernel_do_configure
20 cp ${KERNEL_DEFCONFIG} ${B}/.config 20 cp ${KERNEL_DEFCONFIG} ${B}/.config
21
22 # add config fragments
23 if [ -a "${DELTA_KERNEL_DEFCONFIG}" ]; then
24 merge_config.sh -m .config ${DELTA_KERNEL_DEFCONFIG}
25 fi
21 26
22 # append sdk version in kernel version if SDK_VERSION is defined 27 # append sdk version in kernel version if SDK_VERSION is defined
23 if [ -n "${SDK_VERSION}" ]; then 28 if [ -n "${SDK_VERSION}" ]; then