summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-24 06:59:30 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-06-27 10:40:25 +0800
commitb515997652f0703f333c96a46c66e73e48b4bfbc (patch)
tree609d072bad9b25091be6fd721d2da57291b1b9f0
parentd75b5c38492f5fa821b5b2cca89217bef6868420 (diff)
downloadmeta-fsl-ppc-b515997652f0703f333c96a46c66e73e48b4bfbc.tar.gz
recipes: make meta-fsl-ppc play with other layers
Some recipes are specific to fsl machines but arent marked so. When building images for other machines while including meta-fsl-ppc in bblayers exposes the build failures on these recipes. Lets mark them fsl machine specific Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-test/testfloat/testfloat_2a.bb5
-rw-r--r--recipes-tools/hv-cfg/hv-cfg_git.bb2
-rw-r--r--recipes-tools/rcw/rcw_git.bb2
-rw-r--r--recipes-tools/usdpaa/usdpaa_git.bb3
-rw-r--r--recipes-ucode/fmlib/fmlib_git.bb4
5 files changed, 13 insertions, 3 deletions
diff --git a/recipes-test/testfloat/testfloat_2a.bb b/recipes-test/testfloat/testfloat_2a.bb
index ece8c18..8db41b8 100644
--- a/recipes-test/testfloat/testfloat_2a.bb
+++ b/recipes-test/testfloat/testfloat_2a.bb
@@ -6,10 +6,11 @@ LIC_FILES_CHKSUM = "file://testfloat/testfloat.txt;beginline=87;endline=95;md5=b
6 6
7SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \ 7SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \
8 http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \ 8 http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \
9 file://SoftFloat-powerpc-1.patch \
10 file://TestFloat-powerpc-E500v2-SPE-1.patch \
11 file://Yocto-replace-COMPILE_PREFIX-gcc.patch \ 9 file://Yocto-replace-COMPILE_PREFIX-gcc.patch \
12 " 10 "
11SRC_URI_append_fslmachine = " file://SoftFloat-powerpc-1.patch \
12 file://TestFloat-powerpc-E500v2-SPE-1.patch \
13 "
13SRC_URI[TestFloat.md5sum] = "4dc889319ae1e0c5381ec511f784553a" 14SRC_URI[TestFloat.md5sum] = "4dc889319ae1e0c5381ec511f784553a"
14SRC_URI[TestFloat.sha256sum] = "84d14aa42adefbda2ec9708b42946f7fa59f93689b042684bd027863481f8e4e" 15SRC_URI[TestFloat.sha256sum] = "84d14aa42adefbda2ec9708b42946f7fa59f93689b042684bd027863481f8e4e"
15SRC_URI[SoftFloat.md5sum] = "b4a58b5c941f1a2317e4c2500086e3fa" 16SRC_URI[SoftFloat.md5sum] = "b4a58b5c941f1a2317e4c2500086e3fa"
diff --git a/recipes-tools/hv-cfg/hv-cfg_git.bb b/recipes-tools/hv-cfg/hv-cfg_git.bb
index 3126138..d675a41 100644
--- a/recipes-tools/hv-cfg/hv-cfg_git.bb
+++ b/recipes-tools/hv-cfg/hv-cfg_git.bb
@@ -15,6 +15,8 @@ DEPENDS += "dtc-native"
15# this package is specific to the machine itself 15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1" 16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}" 17PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_HOST_fslmachine = ".*"
19COMPATIBLE_HOST ?= "(none)"
18 20
19inherit deploy 21inherit deploy
20 22
diff --git a/recipes-tools/rcw/rcw_git.bb b/recipes-tools/rcw/rcw_git.bb
index 625bd60..f33685d 100644
--- a/recipes-tools/rcw/rcw_git.bb
+++ b/recipes-tools/rcw/rcw_git.bb
@@ -8,6 +8,8 @@ LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b
8# this package is specific to the machine itself 8# this package is specific to the machine itself
9INHIBIT_DEFAULT_DEPS = "1" 9INHIBIT_DEFAULT_DEPS = "1"
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_HOST_fslmachine = ".*"
12COMPATIBLE_HOST ?= "(none)"
11 13
12inherit deploy 14inherit deploy
13 15
diff --git a/recipes-tools/usdpaa/usdpaa_git.bb b/recipes-tools/usdpaa/usdpaa_git.bb
index 3138675..f76ee1d 100644
--- a/recipes-tools/usdpaa/usdpaa_git.bb
+++ b/recipes-tools/usdpaa/usdpaa_git.bb
@@ -12,6 +12,9 @@ RDEPENDS_${PN} = "libgcc"
12SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git" 12SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git"
13SRCREV = "670ad8827fd83169ccb54a008c638dbb497b1c61" 13SRCREV = "670ad8827fd83169ccb54a008c638dbb497b1c61"
14 14
15COMPATIBLE_HOST_fslmachine = ".*"
16COMPATIBLE_HOST ?= "(none)"
17
15S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
16 19
17EXTRA_OEMAKE = 'V=1 CC="${CC}" LD="${LD}" AR="${AR}"' 20EXTRA_OEMAKE = 'V=1 CC="${CC}" LD="${LD}" AR="${AR}"'
diff --git a/recipes-ucode/fmlib/fmlib_git.bb b/recipes-ucode/fmlib/fmlib_git.bb
index 038f899..dd67b7b 100644
--- a/recipes-ucode/fmlib/fmlib_git.bb
+++ b/recipes-ucode/fmlib/fmlib_git.bb
@@ -16,9 +16,11 @@ S = "${WORKDIR}/git"
16TARGET_ARCH_FMLIB = "${DEFAULTTUNE}" 16TARGET_ARCH_FMLIB = "${DEFAULTTUNE}"
17TARGET_ARCH_FMLIB_e5500 = "ppc32e5500" 17TARGET_ARCH_FMLIB_e5500 = "ppc32e5500"
18TARGET_ARCH_FMLIB_e6500 = "ppc32e6500" 18TARGET_ARCH_FMLIB_e6500 = "ppc32e6500"
19COMPATIBLE_HOST_fslmachine = ".*"
20COMPATIBLE_HOST ?= "(none)"
19 21
20EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \ 22EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \
21 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_EXECPREFIXDIR}" 23 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_EXECPREFIXDIR}"
22 24
23do_compile () { 25do_compile () {
24 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a 26 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a