summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-01-06 21:21:31 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:14 +0800
commitb43988274a42969bfc1fe5f6b6577547c5340f55 (patch)
tree6d8c0697c84f5f505ae739ac9921dd3d15d109f2
parentbd1037cf138dd0fa168460bb68812961504c3a7e (diff)
downloadmeta-fsl-ppc-b43988274a42969bfc1fe5f6b6577547c5340f55.tar.gz
asf: update to a8bbba6
Changelog: a8bbba6 Adding missing NULL checks for pointers a57b54c ASF: Fix for compilation error in IPSEC 4c1e657 IPSEC: Fix for crash with RedSide disabled. 53c68a9 ASFQOS: Removing Compilation errors. a2435dd ASF: Changing dpa files path and Flag 03d158e asf: Patch to fix api issue in kernel change. 30fe696 asf_ipsec: Patch to fix the insmod issue with gcc5.2 705730c asf: Patch to remove compilation error when ASF_IPV6 is disabled. 08c71f3 asfipsec: Patch to linearize nr_frag and fraglist coming from linux. Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/asf/asf/0001-asf_ipsec-Patch-to-fix-the-insmod-issue-with-gcc5.2.patch69
-rw-r--r--recipes-kernel/asf/asf_git.bb4
2 files changed, 71 insertions, 2 deletions
diff --git a/recipes-kernel/asf/asf/0001-asf_ipsec-Patch-to-fix-the-insmod-issue-with-gcc5.2.patch b/recipes-kernel/asf/asf/0001-asf_ipsec-Patch-to-fix-the-insmod-issue-with-gcc5.2.patch
new file mode 100644
index 0000000..bc7ff46
--- /dev/null
+++ b/recipes-kernel/asf/asf/0001-asf_ipsec-Patch-to-fix-the-insmod-issue-with-gcc5.2.patch
@@ -0,0 +1,69 @@
1From 30fe6960f9e8ca035641d87344aa1cf4aca54979 Mon Sep 17 00:00:00 2001
2From: Sandeep Malik <Sandeep.Malik@freescale.com>
3Date: Tue, 5 Jan 2016 17:57:29 +0530
4Subject: [PATCH] asf_ipsec: Patch to fix the insmod issue with gcc5.2
5
6When asf_ipsec module compiled with gcc5.2 is insmod;
7it fails to load with an error "Unknown Symbol". The
8issue is that the newer compiler does strict checking
9for inline functions.
10
11Signed-off-by: Sandeep Malik <Sandeep.Malik@nxp.com>
12
13QASF-1430
14---
15 asfmodule/asfipsec/driver/ipseccmn.h | 5 +++++
16 asfmodule/asfipsec/driver/ipsecfp.c | 5 -----
17 asfmodule/asfipsec/driver/ipsecfp_ah.c | 4 ----
18 3 files changed, 5 insertions(+), 9 deletions(-)
19
20diff --git a/asfmodule/asfipsec/driver/ipseccmn.h b/asfmodule/asfipsec/driver/ipseccmn.h
21index 1dd44fa..8731fba 100644
22--- a/asfmodule/asfipsec/driver/ipseccmn.h
23+++ b/asfmodule/asfipsec/driver/ipseccmn.h
24@@ -44,6 +44,11 @@ extern unsigned int *pulVSGL2blobMagicNumber;
25 extern unsigned int **pulTunnelMagicNumber;
26 extern unsigned int ulTimeStamp_g;
27
28+static inline ASF_void_t secfp_SkbFree(ASF_void_t *freeArg)
29+{
30+ ASFSkbFree(freeArg);
31+}
32+
33 #define ASFIPSEC_ERR asf_err
34 #define ASFIPSEC_DPERR asf_dperr
35
36diff --git a/asfmodule/asfipsec/driver/ipsecfp.c b/asfmodule/asfipsec/driver/ipsecfp.c
37index b1c273e..ca1eceb 100644
38--- a/asfmodule/asfipsec/driver/ipsecfp.c
39+++ b/asfmodule/asfipsec/driver/ipsecfp.c
40@@ -278,11 +278,6 @@ void secfp_IVDeInit(void)
41 #endif
42
43
44-inline ASF_void_t secfp_SkbFree(ASF_void_t *freeArg)
45-{
46- ASFSkbFree(freeArg);
47-}
48-
49 void secfp_deInit(void)
50 {
51 ASFIPSEC_PRINT("DeInitializing Sec FP ");
52diff --git a/asfmodule/asfipsec/driver/ipsecfp_ah.c b/asfmodule/asfipsec/driver/ipsecfp_ah.c
53index c2aca1a..c4a681c 100644
54--- a/asfmodule/asfipsec/driver/ipsecfp_ah.c
55+++ b/asfmodule/asfipsec/driver/ipsecfp_ah.c
56@@ -124,10 +124,6 @@ void secfp_prepareAHOutDescriptor(struct sk_buff *skb, void *pData,
57 #ifdef ASFIPSEC_DEBUG_FRAME
58 extern void print_desc(struct talitos_desc *desc);
59 #endif
60-static inline ASF_void_t secfp_SkbFree(ASF_void_t *freeArg)
61-{
62- ASFSkbFree(freeArg);
63-}
64
65 extern __be16 secfp_IPv4_IDs[NR_CPUS];
66 static inline __be16 secfp_getNextId(void)
67--
682.4.3
69
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
index b9d53e6..38a9863 100644
--- a/recipes-kernel/asf/asf_git.bb
+++ b/recipes-kernel/asf/asf_git.bb
@@ -3,8 +3,8 @@ SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD" 3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5 5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.9.x" 6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v2.0.x"
7SRCREV = "9580a629d3aec3ab3c5e152c6693846b96787906" 7SRCREV = "a8bbba6c2fd23bd79446c0ee62e352bfed528fb4"
8 8
9inherit module qoriq_build_64bit_kernel 9inherit module qoriq_build_64bit_kernel
10 10