summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-12-13 15:47:44 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-12-14 13:34:18 +0800
commita2789b3edf0f3fa4a14279e5d0d4c01d40962353 (patch)
treea57ca9da76993af414ea393e6fcded563abb2f85
parent1449b0a14fbf30e8011e775d8bd9e7eb5b518d9d (diff)
downloadmeta-fsl-ppc-a2789b3edf0f3fa4a14279e5d0d4c01d40962353.tar.gz
lttng-modules: build as 64-bit kernel module on e6500
*e6500 is built with 32b rootfs/64b kernel, build asf as 64bit too. *Fix the below build issue on e6500 core: | DEBUG: Executing shell function do_make_scripts | make: Entering directory `.../tmp/sysroots/t4240qds/usr/src/kernel' | CC scripts/mod/empty.o | scripts/mod/empty.c:1:0: error: -mcmodel not supported in this configuration | make[2]: *** [scripts/mod/empty.o] Error 1 | make[1]: *** [scripts/mod] Error 2 | make: *** [scripts] Error 2 Signed-off-by: Chunrong Guo <B40290@freescale.com>
-rw-r--r--recipes-kernel/lttng/lttng-modules_2.3.3.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/lttng/lttng-modules_2.3.3.bbappend b/recipes-kernel/lttng/lttng-modules_2.3.3.bbappend
new file mode 100644
index 0000000..0452d7c
--- /dev/null
+++ b/recipes-kernel/lttng/lttng-modules_2.3.3.bbappend
@@ -0,0 +1,21 @@
1PRINC := "${@int(PRINC) + 1}"
2
3python () {
4 ma = d.getVar("DISTRO_FEATURES", True)
5 arch = d.getVar("OVERRIDES", True)
6
7 # the : after the arch is to skip the message on 64b
8 if not "multiarch" in ma and "e6500:" in arch:
9 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
10
11 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
12
13 if promote_kernel == "1":
14 d.setVar('KERNEL_CC_append', ' -m64')
15 d.setVar('KERNEL_LD_append', ' -melf64ppc')
16
17 error_qa = d.getVar('ERROR_QA', True)
18 if 'arch' in error_qa:
19 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
20}
21