summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-06-14 14:29:07 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:48 +0800
commit85b40a1d06167b4f4f9949377c9f55c08584be64 (patch)
tree4ed47c69199221efc3bfc4898a166df5ded50939
parent30b6558f81d30809db697484fbb5e4329f9835ea (diff)
downloadmeta-fsl-ppc-85b40a1d06167b4f4f9949377c9f55c08584be64.tar.gz
skmm-host: add recipe for sdk v1.6
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r--recipes-kernel/skmm-host/skmm-host_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-kernel/skmm-host/skmm-host_git.bb b/recipes-kernel/skmm-host/skmm-host_git.bb
new file mode 100644
index 0000000..9ce8a1d
--- /dev/null
+++ b/recipes-kernel/skmm-host/skmm-host_git.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "skmm host driver offload data to PCIe EP and push the data en-decrypted back to application"
2SECTION = "c293-skmm-host"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://Makefile;endline=7;md5=edffaac1da9e809ade0d2fcfcc18d8df"
5
6inherit module
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-host.git;nobranch=1"
9SRCREV = "97c9241a359edccdf8913cb9accbfe4ceb511523"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
14
15python () {
16 ma = d.getVar("DISTRO_FEATURES", True)
17 arch = d.getVar("OVERRIDES", True)
18
19 # the : after the arch is to skip the message on 64b
20 if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch):
21 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
22
23 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
24
25 if promote_kernel == "1":
26 d.setVar('KERNEL_CC_append', ' -m64')
27 d.setVar('KERNEL_LD_append', ' -melf64ppc')
28
29 error_qa = d.getVar('ERROR_QA', True)
30 if 'arch' in error_qa:
31 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
32}
33
34FILES_${PN} += "/etc/skmm/"