summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-17 14:10:15 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:41:54 +0800
commit5833216d5d88dae1ee61b6d90c953dbb6f8ab4e8 (patch)
tree00c5bcb3734845d3a07235e53d411c104f56b78b
parentb1fcfb28a4d1b7ddf9b393b697d76256cc52f760 (diff)
downloadmeta-fsl-ppc-5833216d5d88dae1ee61b6d90c953dbb6f8ab4e8.tar.gz
linux-qoriq: fix vmpic_msi_feature not used error
Fix the below 'unused-const-variable' error: .../arch/powerpc/sysdev/fsl_msi.c:661:37: error: 'vmpic_msi_feature' | defined but not used [-Werror=unused-const-variable=] | static const struct fsl_msi_feature vmpic_msi_feature = { | ^~~~~~~~~~~~~~~~~ | cc1: all warnings being treated as errors | make[3]: *** [arch/powerpc/sysdev/fsl_msi.o] Error 1 | make[2]: *** [arch/powerpc/sysdev] Error 2 | make[1]: *** [sub-make] Error 2 | make: *** [__sub-make] Error 2 Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/linux/files/only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch32
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch b/recipes-kernel/linux/files/only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch
new file mode 100644
index 0000000..5f3220d
--- /dev/null
+++ b/recipes-kernel/linux/files/only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch
@@ -0,0 +1,32 @@
1From 15895f6880829ee502f0a48412173fb452b23c0b Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Fri, 17 Jun 2016 10:57:35 +0800
4Subject: [PATCH] only set vmpic_msi_feature if CONFIG_EPAPR_PARAVIRT defined
5
6Upstream-Status: Pending
7
8Signed-off-by: Ting Liu <ting.liu@nxp.com>
9---
10 arch/powerpc/sysdev/fsl_msi.c | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/arch/powerpc/sysdev/fsl_msi.c b/arch/powerpc/sysdev/fsl_msi.c
14index 963661a..95d7111 100644
15--- a/arch/powerpc/sysdev/fsl_msi.c
16+++ b/arch/powerpc/sysdev/fsl_msi.c
17@@ -658,10 +658,12 @@ static const struct fsl_msi_feature ipic_msi_feature = {
18 .msiir_offset = 0x38,
19 };
20
21+#ifdef CONFIG_EPAPR_PARAVIRT
22 static const struct fsl_msi_feature vmpic_msi_feature = {
23 .fsl_pic_ip = FSL_PIC_IP_VMPIC,
24 .msiir_offset = 0,
25 };
26+#endif
27
28 static const struct of_device_id fsl_of_msi_ids[] = {
29 {
30--
311.9.2
32
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb
index 87eebbc..b837e8f 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v2.0.x \ 9SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v2.0.x \
10 file://modify-defconfig-t1040-nr-cpus.patch \ 10 file://modify-defconfig-t1040-nr-cpus.patch \
11 file://fix-the-compile-issue-under-gcc6.patch \ 11 file://fix-the-compile-issue-under-gcc6.patch \
12 file://only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch \
12" 13"
13SRCREV = "bd51baffc04ecc73f933aee1c3a37c8b44b889a7" 14SRCREV = "bd51baffc04ecc73f933aee1c3a37c8b44b889a7"
14 15