summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-06-28 03:38:30 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-01 13:47:48 +0800
commit2c32822a94435a19cbc26072778853ae2ecec4cc (patch)
treea064622565ae4b8c418f4d4b6b076bc223ce8195
parent19fe4d4c1c52f841054dd31ba07bcbe4ed5a6bf5 (diff)
downloadmeta-fsl-ppc-2c32822a94435a19cbc26072778853ae2ecec4cc.tar.gz
u-boot: upgrade to the version of sdk1.4
install the right nand-uboot for p1010rdb and bsc913x. u-boot-with-spl.bin is the right nand-uboot image. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index e322ab7..7427dfc 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -11,9 +11,9 @@ DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc libgcc"
11 11
12inherit deploy 12inherit deploy
13 13
14SRCREV = "7bcd7f45c8974978f8eb73ae4d32e71cb6a49b77" 14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git"
15SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git \ 15SRCREV = "831b30de4b768f0b3b7dbfa11739b14cea612d7e"
16 " 16
17python () { 17python () {
18 ml = d.getVar("MULTILIB_VARIANTS", True) 18 ml = d.getVar("MULTILIB_VARIANTS", True)
19 arch = d.getVar("OVERRIDES", True) 19 arch = d.getVar("OVERRIDES", True)
@@ -68,7 +68,7 @@ do_compile () {
68 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin 68 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin
69 elif [ "${UBOOT_TARGET}" == "u-boot-nand" ];then 69 elif [ "${UBOOT_TARGET}" == "u-boot-nand" ];then
70 if [ "${DEFAULTTUNE}" = "ppce500v2" ];then 70 if [ "${DEFAULTTUNE}" = "ppce500v2" ];then
71 if echo $board |egrep "(P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB)" 2>&1 >/dev/null;then 71 if echo $board |egrep "(P1010RDB|P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB|BSC9131RDB|BSC9132QDS)" 2>&1 >/dev/null;then
72 cp ${S}/${board}/u-boot-with-spl.bin ${S}/${board}/${UBOOT_TARGET}.bin 72 cp ${S}/${board}/u-boot-with-spl.bin ${S}/${board}/${UBOOT_TARGET}.bin
73 fi 73 fi
74 else 74 else