summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-09-10 15:37:55 -0500
committerMatthew McClintock <msm@freescale.com>2012-09-10 15:37:55 -0500
commit2bed6211ef8e9796131f7de021f65f67b4b3203a (patch)
tree5a60ec6ac2ca4273fa6d1ec1dd621a7a93ed080b
parente68ad0cc18e68e8af3b379efb9cd30efbec2df76 (diff)
downloadmeta-fsl-ppc-1.3_M4.tar.gz
lxc_0.8.0-rc1.bb: initial add of recipe1.3_M4
Signed-off-by: Matthew McClintock <msm@freescale.com>
-rw-r--r--recipes-tools/lxc/lxc_0.8.0-rc1.bb34
-rw-r--r--recipes-tools/lxc/noldconfig.patch29
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-tools/lxc/lxc_0.8.0-rc1.bb b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
new file mode 100644
index 0000000..d5e145f
--- /dev/null
+++ b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "lxc aims to use these new functionnalities to provide an userspace container object"
2SECTION = "console/utils"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
5PRIORITY = "optional"
6DEPENDS = "libxml2 libcap"
7RDEPENDS_${PN} = " \
8 rsync \
9 gzip \
10 libcap-bin \
11 perl-module-strict \
12 perl-module-getopt-long \
13 perl-module-vars \
14 perl-module-warnings-register \
15 perl-module-exporter \
16 perl-module-constant \
17 perl-module-overload \
18 perl-module-exporter-heavy \
19"
20
21SRC_URI = "http://lxc.sourceforge.net/download/lxc/${PN}-${PV}.tar.gz \
22 file://noldconfig.patch \
23 "
24
25SRC_URI[md5sum] ="06ceecf4dbe1be988fc903ad8dd34d29"
26SRC_URI[sha256sum] = "32bf83902c07387646c55de440d6d12cf61bd54c97417109c2d1ac47d17cb911"
27
28S = "${WORKDIR}/${PN}-${PV}"
29
30EXTRA_OECONF = "--disable-doc --disable-rpath"
31
32inherit autotools
33
34FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"
diff --git a/recipes-tools/lxc/noldconfig.patch b/recipes-tools/lxc/noldconfig.patch
new file mode 100644
index 0000000..5edff46
--- /dev/null
+++ b/recipes-tools/lxc/noldconfig.patch
@@ -0,0 +1,29 @@
1From a8aa8d131a7140d5625c24c9f4c28c605213552c Mon Sep 17 00:00:00 2001
2From: Andrey Mazo <ahippo@yandex.ru>
3Date: Fri, 18 May 2012 21:11:22 +0400
4Subject: [PATCH] Avoid ldconfig due to cross-compilation problems.
5
6Make required symlinks manually.
7Otherwise, it cases problems on cbuild endianness != ctarget endianness
8setups because /sbin/ldconfig expects elf header in the wrong endianness.
9---
10 src/lxc/Makefile.am | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/src/lxc/Makefile.am b/src/lxc/Makefile.am
14index 1c26952..3b84c1a 100644
15--- a/src/lxc/Makefile.am
16+++ b/src/lxc/Makefile.am
17@@ -125,8 +125,8 @@ lxc_kill_SOURCES = lxc_kill.c
18
19 install-exec-local: install-soPROGRAMS
20 mv $(DESTDIR)$(libdir)/liblxc.so $(DESTDIR)$(libdir)/liblxc.so.$(VERSION)
21- /sbin/ldconfig -l $(DESTDIR)$(libdir)/liblxc.so.$(VERSION)
22 cd $(DESTDIR)$(libdir); \
23+ ln -sf liblxc.so.$(VERSION) liblxc.so.$(firstword $(subst ., ,$(VERSION))); \
24 ln -sf liblxc.so.$(firstword $(subst ., ,$(VERSION))) liblxc.so
25
26 uninstall-local:
27--
281.7.3.4
29