summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb
new file mode 100644
index 0000000..c32ccb3
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.0.9.bb
@@ -0,0 +1,85 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Gstreamer freescale plugins"
6LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
7SECTION = "multimedia"
8
9DEPENDS = "imx-codec imx-parser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base"
10DEPENDS_append_mx6q = " imx-lib imx-vpu imx-vpuwrap"
11DEPENDS_append_mx6dl = " imx-lib imx-vpu imx-vpuwrap"
12DEPENDS_append_mx6sl = " imx-lib"
13DEPENDS_append_mx6sx = " imx-lib"
14DEPENDS_append_mx6ul = " imx-lib"
15DEPENDS_append_mx7 = " imx-lib"
16
17# For backwards compatibility
18RREPLACES_${PN} = "gst1.0-fsl-plugin"
19RPROVIDES_${PN} = "gst1.0-fsl-plugin"
20RCONFLICTS_${PN} = "gst1.0-fsl-plugin"
21
22LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
23 file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
24 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
25
26SRC_URI = " \
27 ${FSL_MIRROR}/imx-gst1.0-plugin-${PV}.tar.gz \
28"
29
30SRC_URI[md5sum] = "56fc7d4fcbad0ba14739b668793fcf2c"
31SRC_URI[sha256sum] = "4ab74e3660a56c5a79c714b820bb1ce8dd1db5d66c92529b5378bb211cf25896"
32
33S = "${WORKDIR}/imx-gst1.0-plugin-${PV}"
34
35inherit autotools pkgconfig
36
37# Make sure kernel sources are available
38do_configure[depends] += "virtual/kernel:do_shared_workdir"
39
40PLATFORM_mx6 = "MX6"
41PLATFORM_mx6sl = "MX6SL"
42PLATFORM_mx6sx = "MX6SX"
43PLATFORM_mx6ul = "MX6UL"
44PLATFORM_mx7= "MX7D"
45
46# Todo add a mechanism to map possible build targets
47EXTRA_OECONF = "PLATFORM=${PLATFORM} \
48 CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \
49 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
50 ${@base_contains('DISTRO_FEATURES', 'wayland', base_contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
51
52PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
53
54# Add codec list that the beep plugin run-time depended
55BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
56RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
57
58PACKAGECONFIG ?= ""
59PACKAGECONFIG_mx6 = "overlaysink"
60
61
62# FIXME: Add all features
63# feature from excluded mm packages
64PACKAGECONFIG[ac3] += ",,imx-ac3codec,imx-ac3codec"
65# feature from special mm packages
66PACKAGECONFIG[aacp] += ",,imx-aacpcodec,imx-aacpcodec"
67MSDEPENDS = "imx-msparser imx-mscodec"
68PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
69PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
70OVDEPENDS = "virtual/libg2d"
71PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
72
73FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
74
75FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
76FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
77FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
78FILES_${PN}-gplay = "${bindir}/gplay-1.0"
79FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
80FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
81FILES_${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84
85COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"