summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb
new file mode 100644
index 0000000..71d95f1
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.6.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7
8SRCBRANCH ?= "master"
9SRCREV = "67ea62069fca79d65bf244e98ff568d39399fdaf"
10SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
11
12S = "${WORKDIR}/git"
13
14inherit waf
15
16# configure the eglvivsink element to use the appropiate EGL platform code
17# X11 if x11 is present in DISTRO_FEATURES
18# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
19# Framebuffer otherwise
20EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
21 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
22 'fb', d),d)}"
23
24EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
25
26# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
27LIBV = "1.0"
28require recipes-multimedia/gstreamer/gst-plugins-package.inc
29
30# the following line is required to produce one package for each plugin
31PACKAGES_DYNAMIC = "^${PN}-.*"
32
33COMPATIBLE_MACHINE = "(mx6)"