summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch')
-rw-r--r--recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch
new file mode 100644
index 0000000..4f69c78
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.8/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch
@@ -0,0 +1,46 @@
1From: Javier Viguera <javier.viguera@digi.com>
2Date: Mon, 2 Nov 2015 17:52:48 +0100
3Subject: [PATCH] gst1.0-fsl-plugins: fix appending data to variable
4
5FSL_MM_CORE_CFLAGS and FSL_MM_CORE_LIBS where concatenating data at the
6end without adding a blank space between additions.
7
8As the appended data was a result of `pkg-config` expansion, this was
9working correctly until pkg-config v0.28 because it was pkg-config who
10was adding the trailing space.
11
12But after pkg-config v0.28, specifically in this commit:
13
14http://cgit.freedesktop.org/pkg-config/commit/?id=f26a505826acec6b1e1af8d1efdf959913421c3a
15
16this is no longer true, so the configure script needs to add that space.
17
18Signed-off-by: Javier Viguera <javier.viguera@digi.com>
19---
20 configure.ac | 10 +++++-----
21 1 file changed, 5 insertions(+), 5 deletions(-)
22
23diff --git a/configure.ac b/configure.ac
24index 4da48867fafd..01bff6ca5348 100755
25--- a/configure.ac
26+++ b/configure.ac
27@@ -203,14 +203,14 @@ AC_SUBST(RT_CFLAGS)
28 AC_SUBST(RT_LIBS)
29
30 FSL_MM_CORE_CFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null`
31-FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null`
32-FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslparser 2>/dev/null`
33-FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null`
34+FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null`"
35+FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslparser 2>/dev/null`"
36+FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null`"
37 AC_SUBST(FSL_MM_CORE_CFLAGS)
38
39 FSL_MM_CORE_LIBS=`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null`
40-FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvideocodec 2>/dev/null`
41-FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslparser 2>/dev/null`
42+FSL_MM_CORE_LIBS+=" `$PKG_CONFIG --libs libfslvideocodec 2>/dev/null`"
43+FSL_MM_CORE_LIBS+=" `$PKG_CONFIG --libs libfslparser 2>/dev/null`"
44 AC_SUBST(FSL_MM_CORE_LIBS)
45
46 EXTRAPLATFORMCFLAGS="-DARM -D_GNUC_"