summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-xserver')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf16
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/mx6/xorg.conf14
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/mxs/xorg.conf12
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend2
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/aarch64.patch35
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/crosscompile.patch22
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch15
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch25
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/mips64-compiler.patch29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.14.4.bb35
10 files changed, 205 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf
new file mode 100644
index 0000000..a99e6f2
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf
@@ -0,0 +1,16 @@
1Section "Device"
2 Identifier "i.MX Accelerated Framebuffer Device"
3 Driver "imx"
4 Option "fbdev" "/dev/fb0"
5 # This option only recognized when "mxc_epdc_fb" frame buffer driver in
6 # use. Values are "RGB565" (default, 16-bit RGB), "Y8" (8-bit gray),
7 # and "Y8INV" (8-bit gray inverted).
8 Option "FormatEPDC" "Y8INV"
9EndSection
10
11Section "ServerFlags"
12 Option "BlankTime" "0"
13 Option "StandbyTime" "0"
14 Option "SuspendTime" "0"
15 Option "OffTime" "0"
16EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6/xorg.conf
new file mode 100644
index 0000000..b89bed6
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6/xorg.conf
@@ -0,0 +1,14 @@
1Section "Device"
2 Identifier "i.MX Accelerated Framebuffer Device"
3 Driver "vivante"
4 Option "fbdev" "/dev/fb0"
5 Option "vivante_fbdev" "/dev/fb0"
6 Option "HWcursor" "false"
7EndSection
8
9Section "ServerFlags"
10 Option "BlankTime" "0"
11 Option "StandbyTime" "0"
12 Option "SuspendTime" "0"
13 Option "OffTime" "0"
14EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/mxs/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/mxs/xorg.conf
new file mode 100644
index 0000000..79b6c0f
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/mxs/xorg.conf
@@ -0,0 +1,12 @@
1Section "Device"
2 Identifier "Kernel Framebuffer Device"
3 Driver "fbdev"
4 Option "fbdev" "/dev/fb0"
5EndSection
6
7Section "ServerFlags"
8 Option "BlankTime" "0"
9 Option "StandbyTime" "0"
10 Option "SuspendTime" "0"
11 Option "OffTime" "0"
12EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
new file mode 100644
index 0000000..ceb438e
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
@@ -0,0 +1,2 @@
1# Append path for freescale layer to include bsp xorg.conf
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/aarch64.patch b/recipes-graphics/xorg-xserver/xserver-xorg/aarch64.patch
new file mode 100644
index 0000000..045e24a
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/aarch64.patch
@@ -0,0 +1,35 @@
1Subject: Add AArch64 support to xserver-xorg
2Author: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
3
4lnx_video.c parts are not existing in 1.14 branch.
5
6Xserver was checked in AArch64 fastmodel (commercial one with graphics support).
7
8http://patchwork.freedesktop.org/patch/12785/
9
10Upstream-Status: Pending
11
12---
13 include/servermd.h | 7 +++++++
14 1 files changed, 7 insertions(+), 0 deletions(-)
15
16--- xorg-server-1.13.1.orig/include/servermd.h
17+++ xorg-server-1.13.1/include/servermd.h
18@@ -243,10 +243,17 @@ SOFTWARE.
19 #define BITMAP_BIT_ORDER LSBFirst
20 #define GLYPHPADBYTES 4
21 /* ???? */
22 #endif /* AMD64 */
23
24+#if defined(__aarch64__) || defined(aarch64) || defined(__aarch64)
25+#define IMAGE_BYTE_ORDER MSBFirst
26+#define BITMAP_BIT_ORDER MSBFirst
27+#define GLYPHPADBYTES 4
28+/* ???? */
29+#endif /* AArch64 */
30+
31 #if defined(SVR4) && (defined(__i386__) || defined(__i386) ) || \
32 defined(__alpha__) || defined(__alpha) || \
33 defined(__i386__) || \
34 defined(__s390x__) || defined(__s390__)
35
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/crosscompile.patch b/recipes-graphics/xorg-xserver/xserver-xorg/crosscompile.patch
new file mode 100644
index 0000000..2f98bb8
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/crosscompile.patch
@@ -0,0 +1,22 @@
1Upstream-Status: Inappropriate [configuration]
2
3diff --git a/configure.ac b/configure.ac
4index b3b752c..600500b 100644
5--- a/configure.ac
6+++ b/configure.ac
7@@ -523,13 +523,9 @@ dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d,
8 dnl otherwise uses standard subdirectories of FONTROOTDIR. When cross
9 dnl compiling, assume default font path uses standard FONTROOTDIR directories.
10 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/"
11-if test "$cross_compiling" != yes; then
12- AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d],
13- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'],
14- [case $host_os in
15+ case $host_os in
16 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;;
17- esac])
18-fi
19+ esac
20 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]),
21 [ FONTPATH="$withval" ],
22 [ FONTPATH="${DEFAULT_FONT_PATH}" ])
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch b/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch
new file mode 100644
index 0000000..2f62972
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch
@@ -0,0 +1,15 @@
1Upstream-Status: Pending
2
3Index: git/os/osdep.h
4===================================================================
5--- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100
6+++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100
7@@ -92,7 +92,7 @@
8 * like sysconf(_SC_OPEN_MAX) is not supported.
9 */
10
11-#if OPEN_MAX <= 256
12+#if 0
13 #define MAXSOCKS (OPEN_MAX - 1)
14 #else
15 #define MAXSOCKS 256
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch b/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
new file mode 100644
index 0000000..ec0eea6
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
@@ -0,0 +1,25 @@
1This is the revised version of files/macro_tweak.patch for
2xorg-server 1.8.99.904 and newer.
3
4Upstream-Status: Pending
5
6Signed-off-by: Yu Ke <ke.yu@intel.com>
7
8diff --git a/xorg-server.m4 b/xorg-server.m4
9index bdecf62..040fdb8 100644
10--- a/xorg-server.m4
11+++ b/xorg-server.m4
12@@ -28,10 +28,12 @@ dnl
13 # Checks for the $1 define in xorg-server.h (from the sdk). If it
14 # is defined, then add $1 to $REQUIRED_MODULES.
15
16+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
17+
18 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
19 AC_REQUIRE([PKG_PROG_PKG_CONFIG])
20 SAVE_CFLAGS="$CFLAGS"
21- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
22+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
23 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
24 #include "xorg-server.h"
25 #if !defined $1
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/mips64-compiler.patch b/recipes-graphics/xorg-xserver/xserver-xorg/mips64-compiler.patch
new file mode 100644
index 0000000..168368e
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/mips64-compiler.patch
@@ -0,0 +1,29 @@
1on mips64/n64 pointers are 64bit therefore the pointer conversions to int dont work well
2so we end up with incompatible conversion errors
3
4This patch choses the right values for mips64
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8Upstream-Status: Pending
9Index: xorg-server-1.13.0/hw/xfree86/common/compiler.h
10===================================================================
11--- xorg-server-1.13.0-orig/hw/xfree86/common/compiler.h 2012-06-14 23:04:29.000000000 +0300
12+++ xorg-server-1.13.0/hw/xfree86/common/compiler.h 2012-11-08 10:06:50.865831783 +0200
13@@ -101,6 +101,7 @@
14 #if defined(NO_INLINE) || defined(DO_PROTOTYPES)
15 #if !defined(__arm__)
16 #if !defined(__sparc__) && !defined(__sparc) && !defined(__arm32__) && !defined(__nds32__) \
17+ && !defined(__mips64) \
18 && !(defined(__alpha__) && defined(linux)) \
19 && !(defined(__ia64__) && defined(linux)) \
20
21@@ -721,7 +722,7 @@
22 }
23
24 #elif defined(__mips__) || (defined(__arm32__) && !defined(__linux__))
25-#ifdef __arm32__
26+#if defined (__arm32__) || defined (__mips64)
27 #define PORT_SIZE long
28 #else
29 #define PORT_SIZE short
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.14.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.4.bb
new file mode 100644
index 0000000..c6e23be
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.4.bb
@@ -0,0 +1,35 @@
1require recipes-graphics/xorg-xserver/xserver-xorg.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=bc098b9774ed096943f6c37b5beeef13"
4
5# Misc build failure for master HEAD
6SRC_URI += "file://crosscompile.patch \
7 file://fix_open_max_preprocessor_error.patch \
8 file://mips64-compiler.patch \
9 file://aarch64.patch \
10 "
11
12SRC_URI[md5sum] = "9d68a30258c67faa3c036a4a85e8bf97"
13SRC_URI[sha256sum] = "608ccfaafb845f6e559884a30f946d365209172416710d687b190e9e1ff65dc3"
14
15# These extensions are now integrated into the server, so declare the migration
16# path for in-place upgrades.
17
18RREPLACES_${PN} = "${PN}-extension-dri \
19 ${PN}-extension-dri2 \
20 ${PN}-extension-record \
21 ${PN}-extension-extmod \
22 ${PN}-extension-dbe \
23 "
24RPROVIDES_${PN} = "${PN}-extension-dri \
25 ${PN}-extension-dri2 \
26 ${PN}-extension-record \
27 ${PN}-extension-extmod \
28 ${PN}-extension-dbe \
29 "
30RCONFLICTS_${PN} = "${PN}-extension-dri \
31 ${PN}-extension-dri2 \
32 ${PN}-extension-record \
33 ${PN}-extension-extmod \
34 ${PN}-extension-dbe \
35 "