summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb
new file mode 100644
index 0000000..86a6abf
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot"
7
8PV = "v2016.09+git${SRCPV}"
9
10SRCREV = "a3d27ead69a9e84a7794117cf965af20d0cfec4f"
11SRCBRANCH = "2016.09+fslc"
12
13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
14
15S = "${WORKDIR}/git"
16
17inherit fsl-u-boot-localversion
18
19EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
20
21do_configure () {
22 oe_runmake sandbox_defconfig
23}
24
25do_compile () {
26 oe_runmake tools-only
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
32 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
33}
34
35BBCLASSEXTEND = "native nativesdk"