summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc4
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch30
-rwxr-xr-xrecipes-bsp/imx-test/imx-test/clocks.sh29
-rw-r--r--recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch30
-rw-r--r--recipes-bsp/imx-test/imx-test_5.1.bb5
5 files changed, 1 insertions, 97 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index a459ea9..7174b05 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -3,12 +3,10 @@
3SUMMARY = "Test programs for IMX BSP" 3SUMMARY = "Test programs for IMX BSP"
4DESCRIPTION = "Unit tests for the IMX BSP" 4DESCRIPTION = "Unit tests for the IMX BSP"
5SECTION = "base" 5SECTION = "base"
6DEPENDS_mx5 = "virtual/kernel imx-lib imx-vpu"
7DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu" 6DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu"
8DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu" 7DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu"
9DEPENDS_mx6sl = "virtual/kernel imx-lib" 8DEPENDS_mx6sl = "virtual/kernel imx-lib"
10DEPENDS_mx6sx = "virtual/kernel imx-lib" 9DEPENDS_mx6sx = "virtual/kernel imx-lib"
11DEPENDS_mxs = "virtual/kernel"
12DEPENDS_mx6ul = "virtual/kernel imx-lib" 10DEPENDS_mx6ul = "virtual/kernel imx-lib"
13DEPENDS_mx7 = "virtual/kernel imx-lib" 11DEPENDS_mx7 = "virtual/kernel imx-lib"
14 12
@@ -28,8 +26,6 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
28PLATFORM_mx6 = "IMX6Q" 26PLATFORM_mx6 = "IMX6Q"
29PLATFORM_mx6sl = "IMX6SL" 27PLATFORM_mx6sl = "IMX6SL"
30PLATFORM_mx6sx = "IMX6SX" 28PLATFORM_mx6sx = "IMX6SX"
31PLATFORM_mx53 = "IMX53"
32PLATFORM_mx51 = "IMX51"
33PLATFORM_mx7 = "IMX7D" 29PLATFORM_mx7 = "IMX7D"
34PLATFORM_mx6ul = "IMX6UL" 30PLATFORM_mx6ul = "IMX6UL"
35 31
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
deleted file mode 100644
index 7497e91..0000000
--- a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Mon, 19 Jan 2015 16:56:29 -0200
4Subject: [PATCH] Fix build in OpenEmbedded-Core environment
5Organization: O.S. Systems Software LTDA.
6
7Some of the unit-tests were not being built due to differences on how
8the build system behaves when running inside of the OE-Core. This
9fixes those minor issues and increases the number of tests available.
10
11Upstream-Status: Pending
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14
15diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile
16index 92e2901..75d3e78 100755
17--- a/test/ar3k_bt/Makefile
18+++ b/test/ar3k_bt/Makefile
19@@ -21,7 +21,7 @@ all: $(OBJS)
20 CFLAGS += -lbluetooth
21
22 $(OBJDIR)/hciattach-ar3k.bin :
23- $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin
24+ $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin
25
26 clean:
27 rm -f *.o hciattach-ar3k.bin
28--
292.1.4
30
diff --git a/recipes-bsp/imx-test/imx-test/clocks.sh b/recipes-bsp/imx-test/imx-test/clocks.sh
deleted file mode 100755
index 2121bef..0000000
--- a/recipes-bsp/imx-test/imx-test/clocks.sh
+++ /dev/null
@@ -1,29 +0,0 @@
1#!/bin/bash
2
3# This script is taken directly from the section 5.10 of the Freescale Application Note
4# AN4509 and it simple prints the CPU clocks in a nice format
5
6saved_path=$PWD
7if ! mount|grep -sq '/sys/kernel/debug'; then
8 mount -t debugfs none /sys/kernel/debug
9fi
10
11printf "%-24s %-20s %3s %9s\n" "clock" "parent" "use" "flags" "rate"
12
13for foo in $(find /sys/kernel/debug/clock -type d); do
14 if [ "$foo" = '/sys/kernel/debug/clock' ]; then
15 continue
16 fi
17 cd $foo
18 ec="$(cat usecount)"
19 rate="$(cat rate)"
20 flag="$(cat flags)"
21 clk="$(basename $foo)"
22 cd ..
23 parent="$(basename $PWD)"
24 if [ "$parent" = 'clock' ]; then
25 parent=" ---"
26 fi
27 printf "%-24s %-24s %2d %2d %10d\n" "$clk" "$parent" "$ec" "$flag" "$rate"
28 cd $saved_path
29done
diff --git a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch b/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
deleted file mode 100644
index 4fb0564..0000000
--- a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From e559eb0a9573b9011c03efaf42364dce67af893a Mon Sep 17 00:00:00 2001
2From: Lauren Post <lauren.post@freescale.com>
3Date: Tue, 10 Sep 2013 10:58:28 -0500
4Subject: [PATCH] ENGR00279068-2 epdc_test_driver: Update header name change
5 of mxc_epdc.h
6
7Upstream-Status: Pending
8
9Signed-off-by: Lauren Post <lauren.post@freescale.com>
10Signed-off-by: Frank Li <Frank.li@freescale.com>
11---
12 module_test/epdc_test_driver.c | 4 ++--
13 1 file changed, 1 insertions(+), 1 deletions(-)
14
15diff --git a/module_test/epdc_test_driver.c b/module_test/epdc_test_driver.c
16index fb15aec..447246f 100644
17--- a/module_test/epdc_test_driver.c
18+++ b/module_test/epdc_test_driver.c
19@@ -36,7 +36,7 @@
20
21 #include <linux/device.h>
22 #include <linux/mxcfb.h>
23-#include <linux/mxcfb_epdc.h>
24+#include <linux/mxcfb_epdc_kernel.h>
25
26 /* major number of device */
27 static int gMajor;
28--
291.7.9.5
30
diff --git a/recipes-bsp/imx-test/imx-test_5.1.bb b/recipes-bsp/imx-test/imx-test_5.1.bb
index ff42c7f..82df765 100644
--- a/recipes-bsp/imx-test/imx-test_5.1.bb
+++ b/recipes-bsp/imx-test/imx-test_5.1.bb
@@ -2,10 +2,7 @@
2 2
3include imx-test.inc 3include imx-test.inc
4 4
5SRC_URI_append_mx5 = " file://clocks.sh"
6SRC_URI_append_mxs = " file://clocks.sh"
7
8SRC_URI[md5sum] = "5991439d4b20abac1095688164d26f40" 5SRC_URI[md5sum] = "5991439d4b20abac1095688164d26f40"
9SRC_URI[sha256sum] = "042d0b03d7838395a6b35d0ca7159f1f4b6cf3055dcc4a12a1b66488fca987b1" 6SRC_URI[sha256sum] = "042d0b03d7838395a6b35d0ca7159f1f4b6cf3055dcc4a12a1b66488fca987b1"
10 7
11COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7)" 8COMPATIBLE_MACHINE = "(mx6|mx7)"