summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch31
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch51
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb28
3 files changed, 102 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch
new file mode 100644
index 0000000..d25a3ec
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-do-not-use-safe-write.patch
@@ -0,0 +1,31 @@
1From: Otavio Salvador <otavio@ossystems.com.br>
2Subject: [PATCH 2/2] [MX23] Do not use safe write when building for MX23 arch
3
4The change 105ae4a60 include a safe write support for use with MX23
5but does not include a dummy implementation for other architecture
6making build to fail. This add a dummy version to allow the use with
7MX23 arch.
8
9Upstream-Status: Pending
10
11Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
12---
13 arch/arm/plat-mxs/usb_common.c | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/arch/arm/plat-mxs/usb_common.c b/arch/arm/plat-mxs/usb_common.c
17index 700d168..c3bc9a9 100644
18--- a/arch/arm/plat-mxs/usb_common.c
19+++ b/arch/arm/plat-mxs/usb_common.c
20@@ -53,6 +53,8 @@ static void fsl_safe_writel(u32 val32, volatile u32 *addr)
21 {
22 __asm__ ("swp %0, %0, [%1]" : : "r"(val32), "r"(addr));
23 }
24+#else
25+static void fsl_safe_writel(u32 val32, volatile u32 *addr) { }
26 #endif
27
28 void fsl_usb_xcvr_register(struct fsl_xcvr_ops *xcvr_ops)
29--
301.7.10.4
31
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
new file mode 100644
index 0000000..a98878a
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/mx23-dont-mange-IRQ_VDDA_BRNOUT.patch
@@ -0,0 +1,51 @@
1From: Otavio Salvador <otavio@ossystems.com.br>
2Subject: [PATCH 1/2] [MX23] Don't mangle IRQ_VDDA_BRNOUT for MX23 arch
3
4This has been introduced on commit e93820b3 and makes the kernel to
5fail to build for MX23 arch so we avoid the IRQ_VDDA_BRNOUT
6manipulation for MX23 arch as this IRQ is not available on MX23.
7
8Upstream-Status: Pending
9
10Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
11---
12 drivers/power/mxs/linux.c | 6 ++++++
13 1 file changed, 6 insertions(+)
14
15diff --git a/drivers/power/mxs/linux.c b/drivers/power/mxs/linux.c
16index d5185fa..0d6c729 100644
17--- a/drivers/power/mxs/linux.c
18+++ b/drivers/power/mxs/linux.c
19@@ -1171,7 +1171,9 @@ static int __init mxs_bat_init(void)
20 disable_irq(IRQ_DCDC4P2_BRNOUT);
21 disable_irq(IRQ_BATT_BRNOUT);
22 disable_irq(IRQ_VDDD_BRNOUT);
23+#ifndef CONFIG_ARCH_MX23
24 disable_irq(IRQ_VDDA_BRNOUT);
25+#endif
26 if (no_battery)
27 disable_irq(IRQ_VDDIO_BRNOUT);
28 #ifndef CONFIG_ARCH_MX28
29@@ -1184,7 +1186,9 @@ static int __init mxs_bat_init(void)
30 mxs_set_irq_fiq(IRQ_DCDC4P2_BRNOUT, 1);
31 mxs_set_irq_fiq(IRQ_BATT_BRNOUT, 1);
32 mxs_set_irq_fiq(IRQ_VDDD_BRNOUT, 1);
33+#ifndef CONFIG_ARCH_MX23
34 mxs_set_irq_fiq(IRQ_VDDA_BRNOUT, 1);
35+#endif
36 if (no_battery)
37 mxs_set_irq_fiq(IRQ_VDDIO_BRNOUT, 1);
38 #ifndef CONFIG_ARCH_MX28
39@@ -1199,7 +1203,9 @@ static int __init mxs_bat_init(void)
40 enable_irq(IRQ_DCDC4P2_BRNOUT);
41 enable_irq(IRQ_BATT_BRNOUT);
42 enable_irq(IRQ_VDDD_BRNOUT);
43+#ifndef CONFIG_ARCH_MX23
44 enable_irq(IRQ_VDDA_BRNOUT);
45+#endif
46 if (no_battery)
47 enable_irq(IRQ_VDDIO_BRNOUT);
48 #ifndef CONFIG_ARCH_MX28
49--
501.7.10.4
51
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index 289b536..e74924a 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,27 +1,39 @@
1# Copyright (C) 2011-2012 Freescale Semiconductor 1# Copyright (C) 2011-2012 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4PR = "${INC_PR}.0" 4PR = "${INC_PR}.1"
5 5
6include linux-imx.inc 6include linux-imx.inc
7 7
8COMPATIBLE_MACHINE = "(mxs|mx5)" 8COMPATIBLE_MACHINE = "(mxs|mx5)"
9 9
10# Revision of imx_2.6.35_10.12.01 branch
11SRCREV_mxs = "a0e8d80376957175e959f70aba51a1cae487e414"
12LOCALVERSION = "-10.12.01+yocto-${DATE}"
13
10# Revision of imx_2.6.35_11.09.01 branch 14# Revision of imx_2.6.35_11.09.01 branch
11SRCREV = "3e2396eddb362ff70ee6eac43fb1f27f217dc0d1" 15SRCREV_mx5 = "3e2396eddb362ff70ee6eac43fb1f27f217dc0d1"
16LOCALVERSION = "-11.09.01+yocto-${DATE}"
12 17
13SRC_URI += "file://0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch \ 18SRC_URI += "file://0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch \
14 file://egalax_ts-enable-single-event-support.patch \
15 file://NFS-Fix-nfsroot-support.patch \ 19 file://NFS-Fix-nfsroot-support.patch \
16 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \ 20 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
17 file://no-unaligned-access.patch \ 21 file://no-unaligned-access.patch \
18 file://mx28-removecpufreq.patch \
19 file://mxs-duart-use-ttyAMA-for-device-name.patch \
20 file://w1-fix-support-multiple-master.patch \ 22 file://w1-fix-support-multiple-master.patch \
21 file://smsc95xx-randomize-mac-once.patch \ 23 file://smsc95xx-randomize-mac-once.patch \
22 file://dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch \ 24 file://dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch \
23 file://wire-up-sys_accept4-on-ARM.patch \ 25 file://wire-up-sys_accept4-on-ARM.patch \
24 file://0001-mx53_loco-add-USR-led-support.patch \ 26"
25 file://002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch \ 27
26 file://003_Sanitise_ipu_interrupt_return_value.patch \ 28SRC_URI_append_mxs = " \
29 file://mx23-do-not-use-safe-write.patch \
30 file://mx23-dont-mange-IRQ_VDDA_BRNOUT.patch \
31 file://mxs-duart-use-ttyAMA-for-device-name.patch \
32"
33
34SRC_URI_append_mx5 = " \
35 file://egalax_ts-enable-single-event-support.patch \
36 file://0001-mx53_loco-add-USR-led-support.patch \
37 file://002_Return_ERESTARTSYS_from_IPU_GET_EVENT.patch \
38 file://003_Sanitise_ipu_interrupt_return_value.patch \
27" 39"