summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2015-11-05 10:27:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-11-05 10:17:56 -0200
commite519d6c6a069f8e844b28b08963cea2efb0fd64d (patch)
treeddc5889e6c44e400d77a927c72eee9175f3746e2 /recipes-multimedia
parente6bcd54a5a0f634ed521f2e59ad51b944f72734d (diff)
downloadmeta-fsl-arm-e519d6c6a069f8e844b28b08963cea2efb0fd64d.tar.gz
libimxvpuapi: Add new recipe
This is a library for using the i.MX6 VPU. It is an alternative to libfslvpuwrap, hosted on Github, and has an API that features several improvements over libfslvpuwrap, which include: * User-defined context information associated with input frames, which is passed on to corresponding output frames (to be able to identify which input frame produced which output frame) * Groundwork for future DMA-BUF/BMM/ION/CMA allocator integration, using file descriptors instead of physical addresses * Indicators for when it is safe to try to decode frames, which is critical in multi-threaded playback cases * Simplified, higher-level JPEG en/decoding API, based on the VPU MJPEG codec; useful for picture viewing without the extra boilerplate for VPU-based en/decoding Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi_0.10.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi_0.10.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi_0.10.0.bb
new file mode 100644
index 0000000..2481bf8
--- /dev/null
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi_0.10.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "frontend for the i.MX6 VPU hardware video engine"
2HOMEPAGE = "https://github.com/Freescale/libimxvpuapi"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia"
6DEPENDS = "imx-vpu"
7
8SRCBRANCH ?= "master"
9SRCREV = "d44fb50780b9de319315cf2f0423def47b58df78"
10SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}"
11
12S = "${WORKDIR}/git"
13
14inherit waf pkgconfig
15
16COMPATIBLE_MACHINE = "(mx6q|mx6dl)"